Corrupt layer switching presets during midi


I’ve had my v4.4 kit for about a week. It takes some getting used to, but it seems like I can do a ton with it.

I have a NDLR (basically an arpeggiator) and I’ve been trying to use the Zynthian as a sound module for its different parts. My issue comes up when I have a track playing and I change presets. This works once or twice and then the layer stops playing, even after reboot. Only removing and replacing the layer brings things back. How would I go about helping debug this? I’ve been doing this with a Surge layer so far, but it may have happened with a dexed layer.

I have recently switched to the testing branch and have noticed this too.

I have experienced this with several engines, from memory TAL NoiseMaker, FluidSynth, and LinuxSampler. Sometimes I am able to regain responsiveness after sending stop and all notes off messages from an external controller, but as you found, removing the layer is the only sure way to fix it. Even restarting isn’t a guaranteed fix.

I was not experiencing this on the stable version. If you are on the testing branch and aren’t using one of the new features, perhaps reverting to stable will fix this for you?

Unfortunately, I’m already on stable.

Surge engine is not totally stable and sometimes it fails when changing presets. This could be improved by recompiling the engine with the latest code updates from surge’s repo.

Regarding Dexed and others, it’s quite stable and it shouldn’t fail. We would need more details about how to reproduce the issue.

@gr0k , could you be more explicit about the kind of issues you are getting on testing branch?


@jofemodo unfortunately work and life has been ridiculous and I haven’t had much chance to play recently, even over the weekend :frowning:

I do remember that I was sequencing from an external device, and had two instruments on the Zynth, each on their own channel. From memory the issue was always with one layer. One would continue to respond correctly, whilst the other layer would stop responding, and then freak out and glitch as it caught up, if it was to return at all.

I definitely tried sending a note-off from an external controller, and tho I cannot be certain, I surely would have tried the panic / all note off function on the Zynthian (I have it mapped to a bold press on one of the gel buttons on the front and would have been reminded of it when removing layers etc)

Removing the layer would fix the issue, but it would soon return after re-adding the instrument.

This happened on the testing branch after you merged the send capture via effect layers feature. (Thank you again :pray: :pray: :pray: ) Prior to my last feature request I had been on a recent stable and hadn’t encountered this issue, even with the same setup (sequencing via external device etc). I haven’t used the testing branch in a while, so can’t say if this issue existed in testing previously.

My Zynth isn’t hooked up at the moment (I had to return some toys to a friend and haven’t got around to plugging everything back in) and I’ve gotta get back to work, but I’ll try to carve out some time over the next couple of days and try to find out more specifically.

1 Like

Nice! Please, try to reproduce the error, and we would do our best to solve it ASAP.

Thanks a lot!

1 Like

Hi @jofemodo

Apologies for the slow reply, it’s the first time I’ve had the chance to even boot up my Zynth since my last message.

I have reproduced this error:

Simple TAL NoiseMaker layer on Midi Channel 5, sequenced from Elektron Digitakt. Using 1m quality MIDI cable (the sssnake from Thomann) going directly from Digitakt MIDI OUT to Zynthian MIDI IN. No effects or complex routings.

I’m running:

zyncoder: testing (26ffaed)
zynthian-ui: testing (044d301)
zynthian-sys: testing (cdd73c9)
zynthian-data: testing (315390c)
zynthian-webconf: testing (38d33ed)

On a recent official (4.1?) kit, with official Raspberry Pi power adapter:

Raspberry Pi 4 Model B Rev 1.4
Soundcard: HifiBerry DAC+ ADC PRO
Display: ZynScreen 3.5 (v1)
Wiring: MCP23017_ZynScreen
GPIO Expander: MCP23017

No temperature issues to speak of.

I wasn’t experiencing this on stable.

This time Panic/all notes off works tho, I can also press stop again on the Digitakt and it also fixes the stuck note. I don’t recall either trick working last time, but my layer setup etc was a little more complex.

It doesn’t happen every time, but often enough to be annoying. In this instance it is far less so as the Zynth is responding to panic and stop messages, but I don’t believe that was the case last time.

I’m going to do another update and see if I’m still experiencing these issues, but I’ve gotta go tend to the rest of the day first.

Will update again later.

Just quickly, I am still experiencing this after updating to the latest testing and restarting, but I THINK I’VE FIGURED IT OUT!!

The Zynth seems to accept multiple PLAY messages, as I can EASILY freak it out by pressing play twice or more times on the Electron.

I’ve really gotta run now I’m already late. Hopefully this helps you track it down @jofemodo

1 Like

When you say “PLAY message”, do you mean the “0xA” MIDI system real-time message?
Currently, this message is not captured by the UI, and AFAIK, sequencer doesn’t either. Although there is some code for managing it, it’s currently disabled.
Perhaps @riban can put some light on this …


Sorry, I don’t understand what the issue is our what you are doing to trigger it.

Aaaah, I can see I have conflated at least two issues here: The stuck notes, and non-responsive layers. Apologies, things have been a bit manic on my end.

I’ve had to give back some toys for a while so can’t test this at the moment, but all being well will have some toys of my own to play with soon. Will do further testing if/when everything comes together.