Damn AudioInjector board :)


#1

I had the time yesterday to start building my next Zynthian (I wanted to test Aeolus :slight_smile: )
I used the AudioInjector board, an unknown HDMI 7" display with touch, and a USB MIDI Interface, starting with the official image.

I had to retry 4 times :stuck_out_tongue:

The first fail was caused by the webconf and the software updates that removed my custom HDMI parameters in config.txt. THRICE! :rage: :slight_smile:

The last was caused by default alsa settings that are not suitable for audioinjector. Solved by restoring settings found here: https://github.com/Audio-Injector/stereo-and-zero

BTW: Yes, as someone alreaty stated, the AudioInjector 40pin connector quality is abysmal and soldering is… well… I have no word to describe it. My first solders when I was a child were way better than those on the board.

Anyway… now it works… :slight_smile:


#2

I have the same experience. This Week :man_student:

And the default settings (Master Hifi) at zero level is very “usefull” too :face_with_symbols_over_mouth:


#3

If you put this:

#NO_ZYNTHIAN_UPDATE

at beginning of conifg.txt, the file wont be modified by zynthian update :wink:


#4

That’s good to know :slight_smile:

Yesterday I solved the “problem” with violence, adding a check just after the boot. If il finds that config.txt is not what it should be (i compare it with a config.txt.OK file) then it restores the file and reboot… :slight_smile:
(It’s good to be root :D)