Dead Zynthian on attempted first startup

I built Zynthian 4.1 kit last night with an RPi4 that I’ve had a while. The RPi4 was working fine before the build. However, I flashed an SD card today and tried to do the first boot. When I plug the DC in to the Zynthian nothing at all happens. I see no lights on the Raspberry Pi 4. Nothing. I’m using the RPi power supply that I’ve used with RPi4 for many months.

I can’t imagine having done anything during the install that actually harmed the RPi4. Any ideas what could be causing this? Nothing at all on power up; no lights, no nothing. Thanks for any tips.

I have experienced this with RPi’s when an image fails to write correctly to an SD card.

Perhaps try re-imaging the SD card (using the stable image ) and if the card is old, it may be worth trying a newer one.

If this doesn’t help, it might be worth separating it from the Zynthian components and booting it standalone, with an OS image and SD card you know to be good. Doing this will confirm it is still operational.

Others may have further/better advice. I am new to Zynthian.

Fingers crossed for you!

I had a similar scenario which turned out to be an issue with the SD card and the RPi bootloader. I reflashed the SD and then waited quite a while for the RPi to sort itself out. I think the RPi worked out that it needed to boot from SD and all was good. It looked like it was dead for a while.

How did you flash your SD? I have started using Raspberry Pi Imager from here.

Thanks for the suggestions. I’m using Balena Etcher on Windows to flash the sd cards. It’s always worked for me before.

The first card I was trying was a 128GB sd card, which I’d flashed before and used in the standalone RPi4. Then I tried the same 64GB card that had been working with the RPi4 (i.e., tried it on Zynthian with same Raspbian install it had been working fine with before,just to see if I’d get some lights), and then I reflashed that 64GB card with ZynthianOS. None of them seem to work, nothing visible when power connected.

I guess the next step is to disassemble and try RPi4 all by itself. Right now I’m thinking I can do this while the RPi4 is still installed in the case, just disconnect the Hifiberry HAT and the ribbon cable from the RPi4. I think then it’s still secured in Zynthian case but without being connected to anything and I can still power it up.

UPDATE: I got it working! Thanks again for the suggestions.

I did some minimal disassembly to test the Pi with it still mounted in the case ( just removed the Hifiberry HAT) and once I did that I was getting the lights to work on the Pi. I didn’t check, but it seemed to be starting up normally, so I plugged things back in.

I noticed when taking the HAT off that the ribbon’s 40-pin connection to the Zynaptic board was loose. I think that was the problem. I reattached the 40-pin connector on to the Zynaptic board, making sure that it was firm and aligned properly. The 40-pin connectors on the ribbon cable were the biggest problem for me. The instructions have you mount the HAT and the Zynaptic board before attaching the ribbon cable to them, but the amount of cable between the two 40-pin connectors made connecting this way difficult. In redoing the 40-pin connection on the Zynaptic I unscrewed it from the case so I could move it to get a better angle and less tension on the connector while plugging it in. Then screwed the Zynaptic back into case after 40-pin connector was secure.

I found this also! @jofemodo I imagine you’ve built more Zynthian’s than anymore here, what is your experience?

Would you be OK with me updating the wiki to suggest this? Or is there some other reason for the current order?

I always connect the ribbon cable after everything is attached to the case and never had this problem. And believe me, i’ve mounted lots of official kit zynthians :wink:

It’s true that connecting the ribbon can be a little difficult, but you simply “pre-bend” a little bit the ribbon cable before connecting it. Perhaps this “step” could be on the tutorial …