Did anybody get the Hifibrry dacplusadc card working on PI5 with oram?


Did anybody get the Hifiberry dacplusadc card working on PI5 with oram?
The card is shown after typing aplay -l, but jack does not seem to recognise it.
Also with only bookworm flashed on de SD card it does not work.
Who has the solution?

Thanks a lot and enjoy your day,


I’m using the dacplusadcpro, that is similar but not the same. At first, it was failing too, but suddenly, with a recent firmware update, it started to work. Perhaps you could try to force a rpi-update …


Thanks a lot Jofemodo. Unfortunately … no success yet… I will use USB audio for now. Thursday… 2 weeks holiday on an Greek Island… :upside_down_face: After that starting from scratch with a new image.

Wonderful project this. Thanks again!

Hi Guys,
I have the same problem with HifiBerry DAC+ on RPI5 + Oram.
Strangly enough it was working yestarday. Booted from SD card and even from NVME, I set up the Audio to DAC+, booted again and it worked, sound, everything. even performed update, worked after. Today I start it again and GUI keeps restartaing (quite fast, 1-2 seconds). So I have made a fresh SD card with ORAM. No luck, after settings the DAC+ GUI was restarting - showed ERROR. after Update, same story, except it does not show that ERROR message and restarts are much faster. I checked the DAC+ on RPI4 with stable release of ZynthOS, no problem there, so the card is ok.
Back to the PI5 no luck. When I change the Audio to “Dummy” it boots without problems. When I check aplay -l, I can se the DAC+ there together with HDMI’s and Dummies, alsamixer sees it as well, i2cdetect -y 1, shows the card on the correct location 0x4d (I think). When I change te Audio to DAC+, aplay -l no longer shows te card and GUI keeps restarting. Card is working, PI is working so what gives?

Does the name in aplay -l match what is in the configuration line? Sometimes alsa renames devices.

I say alsa, I mean kernel updates.