Digital Inputs from v4.1 extension set [SOLVED!]


I have a problem with using the digital inputs from my extension set.
I build a external box with 16 switches (switching to Ground, no pull up or anything else).
When I check the I2C on the console with
sudo watch ‘i2cget -y 1 0x21 0x12; i2cget -y 1 0x21 0x13’
I can see changing the value when a key is pressed.
In Zynthian I defined the Switches (200-215) and set the to play a Midi Note.
After some reboots, the first 4 or 5 switches are working, but not the others.
When the key works, I can see the Notes in Midi Log, but not the non working.
Any idea where I can have a look, to check whats wrong?

Thanks, Andy

After some testing I found out some constants:

  • after reboot no key is working
  • after " ‘i2cget -y 1 0x21 0x12; i2cget -y 1 0x21 0x13’ " the first 5 keys are working all other dont work. I can see the change of the values in the console when I press any of the 16 keys

Usind Pullup resistors didn´t change anything.

Any ideas, whats wrong or where I can have a look to get the buttons working?

Thanks, Andy

Opened a issue on github:

regards, Andy


I think it’s solved now. Please, update and test …

yes, now everything works, thants for the fast help. Great work.

best regards, Andy