Disabling internal midi routing


Hey, I’ve tried connecting a couple of keyboards (one keyboard via midi channel 1, and another keyboard via midi channel 2) and creating a couple of synths for those channels. However, both keyboards seem to “merge” their messages and only currently active/selected synth plays. I checked admin and saw that both keyboards indeed send their messages via different channels (midi#1 and midi#2), however there’s some internal routing happening that ignores those channels and merges them.

Is there a way to disable this internal merging? I can’t find any documentation or settings in the zynthian ui/admin.

What version of software are you using?

Hi @bagdonas !

  • If you are in stable, you should enable global “Multi-timbral” mode from the admin menu.
  • If you are in Oram, you have several options:
    • You can change your devices to MULTI mode from the global “MIDI input” options in the admin menu
    • You can simply check/uncheck the devices in the “MIDI input” submenu from chain options.


1 Like