Error after beta update system (recipe


#1

Hi… with Gorgona Next, i tried to reload beta plugins for mod. It worked fine until i decided to run beta update_system.sh.

After that, system boots very slowly,
if trying to load a plugin, the zynthian error splash screen (or black screen with a cursor) appears after a while…and returns to snapshot page.
Running zynthian from terminal this is the result

Zyncoder: Zynswitches poll thread created successfully
Zyncoder: MIDI tuning frequency set to 440 Hz (8192)
INFO:root:SWITCHES INIT...
INFO:root:SETUP GPIO SWITCH 0 => 107
INFO:root:SETUP GPIO SWITCH 1 => 23
INFO:root:SETUP GPIO SWITCH 2 => 106
INFO:root:SETUP GPIO SWITCH 3 => 2
DEBUG:root:ZCTRL 'Layer': 0 (0 -> 2), None, None
DEBUG:root:Snapshot Bank '00001' => MIDI bank 0.
DEBUG:root:Snapshot Bank '00002-STANDARD' => MIDI bank 1.
DEBUG:root:Snapshot Bank '00003-MD-SNAPSHOTS' => MIDI bank 2.
DEBUG:root:ZCTRL 'Bank': 0 (0 -> 3), None, None
ERROR:zynautoconnect.zynthian_autoconnect:ERROR Autoconnecting: list index out of range

to be precise, i can’t hear no sound anymore, but it’s not a soundcard issue, but the usb-midi.
Noticed this when i loaded mod-ui. Only serial port is present… even if i unplug-plug usb bidi keyboard, nothing appears…
[update] now serial midi disappeared too.
Can i hope in solving reinstalling something, or reformat sd card and reload fresh image :smile: ?


#2

Hi @ivanmonterosso!

I have not tested this script yet, so i can’t help you very much with it. Perhaps Holger could give some tip, after his zynthian-holidays :grin:

If you want a functional Zynthian, i recommend you to burn a fresh Gorgona Next and update from the admin menu :wink:

Regards,


#3

Hmmmm… that’s really bad. Sorry - but for now I can only help by saying: reinstall an original image.

Next year I will try to organize the recipe system a little bit better and integrate it into Zynthian. Currently I use it for side projects of Zynthian and maybe there are some problems with the original distribution. Sorry again.

Regards, Holger


#4

It’s ok, I have already done this way. Anyway I can confirm you that if upgrading only with zynthian beta everything works …almost… but not related to upgrade. there are some issues regarding linuxsampler present even before it. (Something like zynthian becomes mute after loading some patches)…