External Usb card question - error screeen


#1

I am putting together zynthian with a raspberry tuuch screen. so far I get the UI running ok.
my problem is when using webconf to edit the sound card to use a Linux usb sound card
I get a screen with zynthina error.
I had fallow this page
http://wiki.zynthian.org/index.php/Simple_RPF_Touchscreen_Zynthian

but not shure what to exactly add in the JackD option

the output of aplay -L is below .
Please advice what to add in the jackd option and config area

best

Discard all samples (playback) or generate zero samples (capture)
default:CARD=Device
USB Sound Device, USB Audio
Default Audio Device
sysdefault:CARD=Device
USB Sound Device, USB Audio
Default Audio Device
front:CARD=Device,DEV=0
USB Sound Device, USB Audio
Front speakers
surround21:CARD=Device,DEV=0
USB Sound Device, USB Audio
2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=Device,DEV=0
USB Sound Device, USB Audio
4.0 Surround output to Front and Rear speakers
surround41:CARD=Device,DEV=0
USB Sound Device, USB Audio
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Device,DEV=0
USB Sound Device, USB Audio
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Device,DEV=0
USB Sound Device, USB Audio
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Device,DEV=0
USB Sound Device, USB Audio
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Device,DEV=0
USB Sound Device, USB Audio
IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=Device,DEV=0
USB Sound Device, USB Audio
Direct sample mixing device
dsnoop:CARD=Device,DEV=0
USB Sound Device, USB Audio
Direct sample snooping device
hw:CARD=Device,DEV=0
USB Sound Device, USB Audio
Direct hardware device without any conversions
plughw:CARD=Device,DEV=0
USB Sound Device, USB Audio
Hardware device with all software conversions



#2

I guess this thread can help you: External USB soundcard


#3

thanks for the link , I am still not clear what are the parameters for my card
in the link the usb card has . P70 -t2000 -dalsa -dhw:CODEC -r48000 -p256 -n4 -s -S -Xraw

CODEC = NAME OF card , where do you get all other parameters ?
thanks


#4

Try to use the same parameters from that thread and replace the “CODEC” value by the name of your card. You can get the name with the command $ cat /proc/asound/cards. To run this, you have to connect over SSH on your zynthian with root as user and raspberry as password. Know you how to do this? If not, you can google for “ssh connection with linux/windows/mac”.

I’ve run the command now and got the name “CODEC” to UCA222.

Card list: (/proc/asound/cards)

0 [CODEC ]: USB-Audio - USB Audio CODEC
Burr-Brown from TI USB Audio CODEC at usb-bcm2708_usb-1.2, full speed

See this reply on the thread I told before:

I have zynthian working with a behringer uca222 USB interface.
The web interface didn’t work for me, jack is reading the settings from somewhere else.
What you have to do is to modify the file /root/.jackdrc
Mine look like this:

/usr/bin/jackd -P70 -t2000 -dalsa -dhw:CODEC -r48000 -p256 -n4 -s -S -Xraw

Where “CODEC” is the name of the device (uca222), you can run this command to see the name of your device:

$ cat /proc/asound/cards


#5

Have you tried the “USB device” from the webconf tool audio configuration tab?


#6

I Have use USB Device and still not working

I had try
Soundcard = Usb device
config - empty

jackd option = ackd -P70 -t2000 -dalsa -dhw:USB device -r48000 -p256 -n4 -s -S -Xraw

any advice? I had try 2 usb cards known to work with iinux


#7

The web interface didn’t work for me, jack is reading the settings from somewhere else.
What you have to do is to modify the file /root/.jackdrc


I had problems before configuring the zynthian with USB card on webconf. The thread author told the same.
Pehaps is there a bug with webconf and USB cards?


#8

Pls send photos of the command you got the card name with.
And the webconf screen.
When you type, we don’t know, if the typo is a mistake you really did or just when answering here.


#9

here they go!


#10

Unless you have modified the systemd service units, the official Zynthian SD “Gorgona Omega” will take the Jackd options from the environment, that is set by the webconf tool.

@BalamSoto, you should try the default jackd options from the webconf tool:

-P 70 -t 2000 -s -d alsa -d hw:0 -r 44100 -p 256 -n 2 -X raw

and don’t connect any other USB device while booting the zynthian. In that way you will be sure of getting the device number “0”.

Some work should be done for improving this behaviour, but if you follow the instructions, it should work with any USB compliant soundcard.

Regards,

P.S: If you have been tweaking the configuration by hand, i would recommend to start with a fresh SD image “Gorgona Omega”.


#11

You screenshot says, that it’s 1. And the name would rather be Device


#12

I just re-image the card
try hw:0 = error
1 = same
Device = same


#13

From your “aplay -L” command i see your card is device “0” (DEV=0), so it should work with “-d hw:0”.
Perhaps it doesn’t support the 44100 rate. You could try with “-r 48000”:

-P 70 -t 2000 -s -d alsa -d hw:0 -r 48000 -p 256 -n 2 -X raw

BTW, are you sure that your USB-soundcard works with jackd in Raspbian?

Regards,


#14

Yes the card works fine with plain raspbian
I had used and tested with raspbian, macOs and other linux flavor


#15

Does it make a difference whether you use spaces between parameter key and value?