External USB soundcard


#1

I tried to connect NI Komplete Audio 6 USB audio interface. I changed an audio interface from HiFiBerry to USB by web interface… and no success, no sound… Did I miss something? Thank you, martin


#2

I never tried this device. You should see (google) if it requires some specific configuration with Linux.

Regards,


#3

It is Class Compliant device, so I expected a smooth implementation… I ll check linux issues on web.


#4

Found that alsa supports that card… https://alsa-project.org/main/index.php/Matrix:Module-usb-audio


#5

https://alsa-project.org/main/index.php/Matrix:Vendor-Native_Instruments


#6

Zynthian default configuration is for 2 channels (stereo), so probably you have to do something with it. Perhaps tunning the jackd options in webtool, etc.

Regards,


#7

Thanks. No idea how to do that :slight_smile:


#8

Try to get it running in a standard rasbian environment.
After that we can figure out what information we need.


#9

Thank you. Could you please be more specific? I have no idea what to do. I understand, that I should change the SD card and run Raspberry with the standard OS, but then whan?


#10

Hi,

I am also fighting :japanese_goblin::stuck_out_tongue: with an external sound card to input my electric guitar signal to Zynthian. I am using a really cheap one and I got it apparently detected and accessible for the system.

With:
cat /proc/asound/cards

I got:

0 [sndrpihifiberry]: HifiberryDacp - snd_rpi_hifiberry_dacplus
_ snd_rpi_hifiberry_dacplus_
1 [Device ]: USB-Audio - USB PnP Sound Device
_ C-Media Electronics Inc. USB PnP Sound Device at usb-3f980000.usb-1.2, full spe_
2 [A25 ]: USB-Audio - Axiom Pro 25
_ M-Audio Axiom Pro 25 at usb-3f980000.usb-1.3, full speed_

The “USB PnP Sound Device” is the new audio card, Device 1. A25 is the MIDI keyboard that I have also plugged, Device 2. Device 0 is the HifiberryDac+, which is working fine.

I can control the volume of all the devices via Alsamixer. What I cannot do now is to process the input of the guitar… In fact I don’t know how to do it…

I would like to be able to do it via MOD-UI but I cannot see the USB sound card as an audio input in the left of the pedalboard on the web interface. Do you know if the MOD-UI interface can be configured to use another external card?

Any suggestion please?:kissing_heart::kissing_heart:


#11

In MOD-UI there is a small sign in the bottom line, where you can click on and add additional IOs.

Regards, Holger


#12

Thanks for the response. I am looking for the sign but I do not find it.:sweat_smile:

I can see the MIDI ports (two USB keyboards) but not the new sound card attached via USB (which seems to be recognized by the system).


#13

Hmmmmm… the “sign” was the MIDI-DIN connector icon :smile:

Strange. Perhaps your USB card is not recognized by a linux system? Can you “ssh” to the Zynthian and look at /var/log/syslog or with dmesg if linux can “see” your card?

Regards, Holger


#14

Hmmm, maybe I understood something wrong… sorry. You cnnot add more audio inputs/outputs on the fly with MOD-UI. You only can add MIDI I/O… sorry.

Regards, Holger


#15

Exactly, I cannot add the new analog audio signal from the new sound card into MOD-UI. Maybe I am trying something imposible (which is not unussual, I am a scientist… :grin:).

It is detected by the system, I can even change its values via Alsamixer. Maybe it is related with the jackctl initialisation command.

Many thanks for the help. Best regards,
A.Gordillo


#16

Hello all, so I am interpreting all this as: One CAN’T configure those Externally attached USB Audio Interfaces from the Zynthian MOD-UI… as yet… .
Am I spelling this out correctly enough?
Does Someone now wanna make a complete OSC wrapped HD MIDI slash Audio Interface already? :wink:
Once again: Hi… and I’m old. :smiley:


#17

I have zynthian working with a behringer uca222 USB interface.
The web interface didn’t work for me, jack is reading the settings from somewhere else.
What you have to do is to modify the file /root/.jackdrc
Mine look like this:

/usr/bin/jackd -P70 -t2000 -dalsa -dhw:CODEC -r48000 -p256 -n4 -s -S -Xraw

Where “CODEC” is the name of the device (uca222), you can run this command to see the name of your device:

$ cat /proc/asound/cards


External Usb card question - error screeen
#18

Good work.

Now could we ALSO have a zynthian with no audio ? Very handy as a remote control panel/MIDI in out device… ?

What’s Catalan for pretty please … ?

… rushes off to learn language. . . .

Ara també podríem tenir un zynthian sense àudio? Molt pràctic com a tauler de control remot / MIDI en el dispositiu …?


#19

HI @jnonis!

The jackd parameters should be modified from the webconf’s audio tab.

Regards


#20

So much for my Catalan . . . :frowning: