Fluid synth - MIDI program change not responding


#1

Hello, I updated zynthian after few weeks and I noticed that my MIDI keyboard program change messages do not change instruments of Fluid Synth on Zynthian. This worked fine before. Am I missing something? When I change program on MIDI keyboard, Zynthian shows the detail screen of active fluidsynth instrument, but I can not change the instrument with MIDI PC message from outside of Zynthian.


#2

Hi @pavel!
Currently, the new SubSnapShot (ZS3) system is active by default, capturing the Program Change events. I just added a checkbox to the webconf tool for disabling this feature. It’s in the MIDI section.
If you update your zynthian, you should have this new option available :wink:

Enjoy!


#3

Hi @jofemodo, thank you for your quick reaction! But: I updated Zynthian, new option appeared in MIDI settings section, but it can’t be saved when disabled. When I disable it and hit save button, it gets enabled when the page refreshes itself. And the MIDI program number is still not working with fluidsynth. Can you have a look at it again?


#4

Ok, now I found the problem is more complex, unfortunately. Although I found out that you probably forgot to save the new option ZYNTHIAN_MIDI_PROG_CHANGE_ZS3 to MIDI profile shell file, I edited the profile /zynthian/zynthian-my-data/midi-profiles/default.sh manually and added the option there. So far ok and now the program change event gets to the appropriate fluidsynth layer.

But the expected behavior is such I have MIDI keyboard with “split” feature, part of the keyboard sending note events with one program number, and part of the keyboard sending note events with other program number, eg. bass with piano split, both on the same channel. Now it is not working this way. It looks like fluidsynth on Zynthian completely ignores program number in midi note events.


#5

Also, during my elaboration with MIDI profiles, I found a bug - I happend to accidentally delete the default MIDI profile through the webconf, which lead to 500 errors, not able to open MIDI config page anymore. I think this could be fixed with disallowing to delete default MIDI profile…


#6

Ups! It should be fixed now. Also the problem when deleting default MIDI profile :wink:
BTW, i’ve merged the development branch “fxchain-control” into master, so if you are not using the “fxchain-control” branch, you will note a few changes more when updating :wink:

Enjoy!


#7

Great, thanks!:heart_eyes:


#8

Ehm, after updating, save default snapshot is missing on snapshot button long press…


#9

This has changed. From “load snapshot”, click again snapshot switch, if you use touch, click over zynthian icon.

I will updated documentation ASAP.


#10

Check that you haven’t enabled Single Channel Mode …