Freeze when engine selected, no audio [solved]

I just finished building the Zynthian (with audioinjector) but unfornately I can’t make it work yet.
I can navigate through the menue and go back to the admin screen. reboot, gestart GUI…
But if I select a synth engine, the zynthian logo waveform will move but nothing else happens. I can still select (or rather just highlight) engines with the touchdisplay but the select or the back knob wouldnt work anymore.
Also if I use the test audio function no audio is put out, neither over the mini headphone jack of the raspberry nor the headphone or the actual output jacks of the audioinjector.

So far I coulnt find mistakes in the wiring.

Can someone help me narrow the problem?

ah sorry, let me see if the update will fix this first…
(I downloaded the gorgona image today thou, I dont know if the update was in this inclueded…)

alright, so now I’m a bit further but still nothing is really working how it should ^^

the freezing now happens when I select the linux sampler.
I can enter ZynAddSubFx, select the channel, but then if I select something in the next window I see the fullscreen Zynthian logo and “Error”.
I can enter the fluidsynth without error.
When I enter the organ and then something on the second screen: error again.
When I Test Audio: "ERROR: b’Cannot connect to server socket.

I think the problem is also that I cannot access the alsa mixer (because I cannot access the web configuration tool). I’m on a mac. I got so far now that I connected in the terminal like this:

And I managed to get access to the file system with my ftp programm. But if I enter zynthian.local or http://zynthian.local or zynthian.local:8888 in the browser, nothing would happen. also the option with the zynthian ip adress is not helping
And I dont get what i should write in the wpa_supplicant.conf file.
Sorry this network stuff has always been a riddle to me :-/

Have you tried to open a browser window to your Zynthian and changed the audio card (and rebooted)?

Sorry, I am currently writing from smartphone. So only short answers…

Regards, Holger

Hey Holger, I think so, if we are talking about the same here… isnt that what I did when I entered zynthian.local:8888 in the browser?


there is a difference between the two web pages:

  • zynthian.local:8888 is only shown when started the MOD-UI engine and is only for configuring MOD-UI setups
  • zynthian.local:80 is the “global” configuration screen of your Zynthian. There you can change the parameters for your sound-card, the display, …

So I think you haven’t configured your sound-card yet. The default one should be a Hifiberry…

Regards, Holger

thanks for your help, most of it works now! I think part of the problem also was that I had to update the zynthian software first

1 Like

Still my Zynthian crashes quite often so that i have to pull the power plug, I hope this wont damage the ssd sooner or later… Is that “normal” or a common problem? I dont really know how I could work on this.
Also sometimes it works fine for an hour and then suddenly it crashes every second time I select an engine
(not a specific one, I noticed this with all kinds of engines in zynthian)

do you experience this behaviour when you don’t use mod-ui as well?

yes for example I boot the zynthian, no layer active yet. I go to new layer and then I select Linux sampler, the waveform logo in the right starts moving and wont stop anymore. I shut it down by unpluggin the usb, then I boot it again and suddenly it works.
Sometimes it even crashes when I select the power off button in the admin menue

1 Like

Maybe I should also add that it usually doesnt completely crash. I often can still select things with the touch screen in the menue, but it wont go into the other menue then, just the red highlighting works

You need to stop the zynthian service and start it manually, so that you can see the log messages

what do you mean by stopping the zynthian service? Sorry I dont really get it.
And how can I make log messages visible? I mean I can attach a hdmi screen and a usb keyboard and I see some text running down the hdmi screen when booting but then the display wont show me anything, also not when it crashes again

open ssh shell
systemctl stop zynthian


ok, thank you! I’ve done that now.

This time the crash happened when trying to remove all layers (forgot to mention before that this also was a frequent reason) The crash looks as follows in the terminal:

INFO:root:Short Switch 3
DEBUG:root:WS >> disconnect /graph/dexed_lv2/audio_out /graph/playback_2
DEBUG:root:WS >> disconnect /graph/dexed_lv2/audio_out /graph/playback_1
DEBUG:root:WS >> disconnect /graph/serial_midi_in /graph/dexed_lv2/midi_in
DEBUG:root:WS >> remove :all
DEBUG:root:ZCTRL ‘Layer’: 0 (0 → 2), None, None
INFO:root:Short Switch 1
DEBUG:root:BACK TO SCREEN => admin
DEBUG:root:ZCTRL ‘Action’: 0 (0 → 12), None, None
INFO:root:Short Switch 3
INFO:root:Starting Command Sequence …
INFO:root:Executing Command: mpg123 ./data/audio/test.mp3
INFO:root:Short Switch 3
WARNING:root:zynthian_gui.zyncoder_read() => ‘zynthian_gui_info’ object has no attribute ‘switch_select’
Connection to zynthian closed by remote host.
Connection to zynthian closed.

After the connection allegedly is closed, the zynthian is actually still showing the menue (just as explained above).
And what is also weird is that at this point i did not try to run the test mp3.
(By the way when I do run the audio test I can not go back to the admin menue, it gets stuck in the test.mp3 screen and the audio just keeps playing)
(By the way2: rebooting over zynthian.local is possible)

So, can anyone see something in the log that I posted? Any help much appreciated as always :slight_smile:

Please, update to the last version to see if the problem is solved. If nothing changes, check that your repositories are up-to-date. Run this commands and send the ouput:

cd /zynthian/zynthian-ui
git branch
git checkout .
git pull

cd /zynthian/zynthian-webconf
git pull

cd /zynthian/zynthian-sys
git branch


1 Like

alright, I updated the system one more time, did those repository checks and recreated the default.zss, because there was an error message in the log saying that its missing. I can’t make it crash anymore! At least not like this ^^
Thanks a lot so far!
But now the next issue appears. The Fluid Synth is somehow behaving totally messed up. The GS engine produces no sound anymore and I get:

WARNING:root:SoundFont 1 is not loaded
and when I press a note:
ERROR:root:zynthian_gui.zynmidi_read() => ‘zynthian_engine_fluidsynth’ object has no attribute ‘preset1’

The GM engine only works “sometimes”. Often if would just play the piano sound even if i select a cello for example and when loading one of the patches:

SoundFont 2 is not loaded

I think it’s fixed now. Try updating again :wink:

1 Like

amazing, thanks!! :smiley:
I finally feel complete