Gate?

When using Pianoteq on my Rbpi4 Zynthian, i noticed that the sound quality is not so good as i can hear some noise when i play a note and this noise stops when the note ends.

So i have two questions :

1 - Is there any config to improve sound quality, as i’m using the Pi4 ?

2 - It seems there is a sound gate running all the time, because the sound won’t play all the tail, the gate will cut the note as soon as it reach a minimum level… Where can i find this gate settings ?

Thanks !

Are the CPU or Power Icon light up during your playing? (Triangle or Flash)

No, my Zynthian is upgraded with RbPi4, no cpu issues.

What is your soundcard?

The HifiBerry has one, but you can disabled from the (ALSA) Mixer. As this control is not shown by default in the Zynthian UI, you should navigate to:

webconf->Hardware->Audio->Mixer Controls->[+]

and tweak the “auto-mute” settings.

Please confirm if this works for you …

Thanks!

1 Like

Hi Fi Berry

Will try that tonight, thanks ! And what about the sound quality ? Is there some config i could try to tweak to improve Pianoteq audio ?

You can try to change the Pianoteq’s internal frequency, but you probably get XRuns. Try tweaking this file:

/zynthian/zynthian-ui/zyngine/zynthian_engine_pianoteq.py

at:

Try to increase this value:

PIANOTEQ_CONFIG_INTERNAL_SR=22050

but remember that this will be smashed when you update your zynthian, unless you setup your own repository for zynthian-ui.

Regards,