GPIO Encoder wont start on Pi3 (solved)

Whilst updating a Pi3 on stable.

Oct 15 11:20:33 zynthian-amp startx[489]: gpio: Unable to open GPIO direction interface for pin 7: No such file or directory
Oct 15 11:20:33 zynthian-amp startx[489]: wiringPiISR: unable to open /sys/class/gpio/gpio7/value: No such file or directory

Don’t remember seeing that one before. But it’s about to get a new SSD so it might stop complaining.

Caused by use of a previously working GPIO direct connected Encoders as per :

With wiring selected and above pins it fails to start with above line.

I’ll log a bug.

Caused by spi mode being enabled in raspi-config…

The pin involved was the only pin i’d used in the SPI block GPIO 7,8,9,10,11

D’Oh !

So did you chose different pins or disable SPI? If the latter please share with the class.

Disabled SPI in raspi-config.

Mind you it’s a right old fight as the pi keeps rebooting and you don’t get webconf for more than 10 seconds or so…

Still fighting pin 11 & audio device.

I think this Pi is in for a new stable build.

It’s now working at last …

now that was a bug!! :smiley:

Ok.

Rebuilt on a clean stable…

Configured.

Wouldn’t start.

Updated.
Switched to testing.

Added audio card hifiberry Amp…
Started . . .

Configured wiring as per attached … Same problem …

Turned off SPI in raspi-config now works . . .

So there is something about the hifiberry amp settings and the SPI mechanism…

After a bit of soldering …

Moving the Prviously pin 26, connected to the Back switch to Pin 10 and including 16 in the 2nd position of the Switch settings, we have a functioning zynthi…

And it reboots cleanly!

I notice we have the timeout power off back !! :smiley: Nice.

updated zynthian-alm.local

25,26,4,0
27,21,3,7
23,16,2,22