How to get Pianoteq presets to Zynthian

Hey.

Sorry if this has been asked and discussed before, but I really couldn’t find anything.
How can I get my presets I’ve built on my computer to Zynthian?
When I choose Pianoteq in “Library → Presets and Soundfonts” it just shows white screen.
I also couldn’t find anything from the manual how to manually update files to Zynthian.

I get the part how to actually install them to Pianoteq (via VNC), but how can I get the files into Zynthian?

Please help.

Anyone? :slight_smile:

You can upload files to zynthian using webconf LIBRARY.

When I go to Library and choose Pianotec 7.4 Standard, I get this screen (blank). All others show presets and the ability to upload them.

Please file a new issue here

And attach a preset file (makes it easier for me to develop it)

Done.
Thank you!

There is a bug reported now.
Until I wait for it to resolve, is there another way (manually somehow) how to get pianoteq patch to Zynthian? I just need couple of patches, so it can be tricky and not convenient, I just need it to happen :slight_smile:

Thank you!!

You can try this (as simple as I can make it):

  • Save your fxp file to your local PC
  • Within a web browser, navigate to zynthian webconf LIBRARY->Captures
  • Click the “Upload” button
  • Drag the fxp file to the “Drop files here…” area
  • Click “UPLOAD” - this will put the file on the zynthian in the captures folder (not the right place)
  • Within a web browser, navigate to zynthian webconf INTERFACE->UI Options
  • Enable Advanded view
  • Enable VNC Server
  • Navigate to webconf SOFTWARE->LV2-Plugins
  • Enable Pianoteq
  • Click “Save” button at bottom of screen
  • On the Zynthian add New Synth->LV2 Instrument->Pianoteq
  • Refresh web browser on PC to reload webconf
  • Navigate to INTERFACE->VNC-Engines - this opens another browser tab with VNC access to the zynthian desktop
  • Click “Connect” and login with password (default: raspbian)
  • The top bar has a tab per GUI engine, click on Pianoteq to bring to fore
  • Within Pianoteq native GUI click on the presets drop down->Load an FXP file->Chose FXP file…
  • Navigate to /zynthian/zynthian-my-data/capture
  • Select the fxp file previously uploaded
  • Click on the Floppy disk icon (or select File menu->Save preset)
  • At top of Pianoteq window, click on Presets->Save preset…
  • Enter a name for your preset
  • Repeat for each new preset
  • Within web browser, navigate to webconf SOFTWARE->LV2 Plugins
  • Click “Search for new Plugins & Presets” button
  • Wait - this take ages - a few minutes

You should now be able to select your presets from the Pianoteq LV2 plugin bank called None, i.e. loading LV2 version of Pianoteq in Zynthian and selecting bank “None” then your preset.

Sorry this is long. You don’t need to do all the steps every time as some of these are setting up VNC, etc.

@riban Thank you!

Do you know, how is it going with thad bugfix?

Do you mean this bug? The issue tracker says it is fixed in the testing branch.

Sorry if that’s a stupid question, but to fix it for me I need to use some other branch?
Or wait for the official release? When will that happen do you know?