How to install pianoteq?


I am running the Nov 2022 Zynthian stable build. I have a license for pianoteq 6.7.3 STANDARD.

I am able (using a combination of the web interface and the VNC engine) to

    • upload the binary pianoteq_linux_v673.7z to the zynthian (web interface)
    • add my licence key (in a web VNC window) - pianoteq verifies it and it comes up with my name and address.
    • I quit pianoteq and reboot the Zynthian.

At this stage the zynthian boots with a Red ERROR message and the web interface doesn’t come up. I still have ssh access at this time, but no idea what I need to do to fix the install. As far as I can tell, the only thing I can do is flash a new microsd card with the zynthianOS ?

Is there something I’m missing ? Is this the correct way to install pianoteq on the Zynthian?

Any help appreciated.


Hi @piano.pete!

Nice to meet you! Welcome to our little community!

You should try the webconf tool for:

  • uploading the Pianoteq binary (it seems you already did it)
  • activating the license key => You don’t need the Pianoteq native GUI for it! After uploading the pianoteq binary and rebooting your zynthian, simply access the same webconf page and you should see an input box where you can put your license key.

It should work. I did yesterday with my Pianoteq 7.5 and it worked like a charm :wink:

Best regards!

Hey @jofemodo

Thanks for the fast response.

The problem is that when you upload the binary, the zynthian screen shows the native GUI prompting for the license.

The web conf gui just hangs then while the native GUI is waiting for input.

Could this be something to do with 6.7.3 versus 7.5?


I’ve been doing it several times, reinstalling from scratch, and I haven’t had a single problem. I didn’t have the VNC active, it might be a cause.

I did as @jofemodo explains but I think that you have to reboot after uploading the Pianoteq binary, otherwise you don’t see the license key input form.

1 Like

@pau @jofemodo - thanks for that.

Just flashing the card again and will try as per your suggestion.
Fingers crossed. I will grab the screen during the session.


1 Like

OK - I have solved the problem by upgrading Pianoteq to 7.5.

When I tried to install the pianoteq_linux_v673.7z file, the webconf hung at the

The new file is being installed. Please wait...


The system never returned because pianoteq was running on the Zynthian screen:

(That is what prompted me to use the VNC previously).

As this is clearly not what everyone else was experiencing I bit the bullet and upgraded the license to 8.0, and downloaded the 7.5 binary.

I ssh’d onto the Zynthian and killed off the Pianoteq process, and then reinstalled the 7.5 binary from the webconf.

That worked exactly as @pau and @jofemodo explained. The process finished installing then prompted me to reboot, after which I was able to add my license key.

I can only think that the Zynthian code is specific to certain binaries ?

Anyway, Going to reboot and check how it works when connected to my Nord Piano 3.

Thanks both.

I hadn’t seen that there is a Pianoteq 8 version :slight_smile:
I might upgrade to see what’s new!

Edit: The same license works for version 8, I am not sure if the pianoteq_json_api branch needs a tweak or two to get it working

PT 8 is very new. We will have to do some work to integrate it. You can’t download the later version of PT unless you have a licence that was purchased recently (probably last year or so). I don’t. I may have to upgrade to 8.0 to be able to do the integration work…

PT6 starting on the main UI is wrong so probably a bug and should be added to issue tracker.

[Edit] Thanks to p-philips for adding to web-conf issue tracker. We need to move that to the official issue tracker.

I will try to upgrade to Pianoteq and see if I can make the needed changes. My license works.

Edit: There’s a 25% off now

I haven’t tried the version 8, but the 7.5 standard version is working brilliantly.

Just been playing the grands and the Rhodes MkII. Sounds superb. It’s been a few years since I bothered to connect a laptop to my stage piano, so Pianoteq has been languishing in a dusty corner of my hard drive, but no longer. Some of the Pianoteq Rhodes play much nicer than the Nord Rhodes.

I did put an issue up last night on github but didn’t explain it well enough - will have a look later and update it with the screengrab.

@pau & @jofemodo - once again thanks.

I may take the Zynthian to big band rhsl tomorrow and see what it sounds like through my stage speakers.

Version 8 does not seem to provide substantial improvements. There is support for a new nylon guitar instrument (which you need to buy separately), changes to the native UI, and iOS version and some re-voicing. I guess the iOS version supports the bump to 8.0 but almost nothing that will improve Zynthian experience.

What exactly does this mean?

new feature that seems incredible :
The LV2 / VST3 / AudioUnit plugins can receive an optional audio input, which is used to excite the string resonances (STD/PRO versions).

The original post (no. 15): Pianoteq 8 just been released 16.11.2022 (Page 1) - Pianoteq user forum - Modartt user forum
(and more in reply no. 24)

1 Like

If you have a very loud opera singer to hand they can cause the string resonance to sound as if they’re stood next to a grand piano with an open lid.

Or if you have a hammer you can emulate the sound of fighting the inside of a piano, to be honest I’m not sure.

1 Like

Ah! That is just what I wanted - to emulate the sound my old upright made when I walked across the wooden floor towards it. A combination of bouncy floor and broken dampers made it sing to me in a haunting but pleasing way.


I’m about to take the plunge on Pianoteq. I have three active Zynthians. One in the studio, one for the road, and a road backup. I only run one system at a time. Will I be able to use the license on the 3 different Zynthians that I am running?

Each Pianoteq license may be activated and used on three devices so a single license can be used on all three of your Zynthians. You cannot transfer licenses back and forth. Once you deactivate a license from a device you cannot reactivate on that device. (I suspect this is a mechanism to reduce the risk of piracy and abuse of the fairly generous licensing that Modartt grant.)

1 Like