How to make your pedalboard visible in browser


#1

The story
When i installed Gorgona on a SD-card i tried to make it visible on my webbrowser.

on the webpage:
To access MOD-User Interface (MOD-UI) you can read to access: zynthian.local:8888

The Issue
I didn’t succeed. Nothing was working.
I got: This site can’t be reached. The connection was reset.

The Solution (for me it was)
To make the pedalboard work on your browser, i did the following

  • I work with Windows (I think Linux and Mac will be the same)
  • Install a SSH telnet client. For me it’s called PuTTY
  • Find out what is the IP-address of your Zynthian Rapsberry Pi.
    To find out, there are two ways to do so.

With your (Android) mobile phone. Use the free wifi scanner app FING.
fing

With your computer. Use the free program "Advanced IP scanner"
advanced ipscanner
When starting the scan you wil see: Zynthian 192.168.-.- Raspberry Pi Foundation
Remember this IP-address

  • When installed, open Putty
  • type IP address, Port 22 and click on “Open”
  • A black terminal will appear. You have to login.
  • Login as: root
  • Password: raspberry
    puttyterminal

Now you are in the root of the directory structure of Gorgona Linux.

Start the MOD-UI server

type in Putty:

cd /zynthian/zynthian-sw/mod-ui
./server.py

Go to your browser and type your zynthian IP-address followed by Port 8888
for instance: http://192.168.0.30:8888

The pedalboard will be loaded. (yippie a yeah)

Isn’t MOD-UI working ?
type first:

systemctl start mod-ui

followed by

cd /zynthian/zynthian-sw/mod-ui
./server.py

Do you want to start the MOD-SDK server

type in Putty:

cd /zynthian/zynthian-sw/mod-sdk
./development_server.py

Go to your browser and type your zynthian IP-address followed by Port 9000
for instance: http://192.168.0.30:9000
MOD-SDK will be loaded

Isn’t MOD-SDK working ?
type first:

systemctl start mod-sdk

followed by

cd /zynthian/zynthian-sw/mod-sdk
./development_server.py

I hope this will do the trick also for you.

Good luck
Regards,
JanR


#2

Hi @Janr !

There is an option in the menu of the zynthian UI (the menu page where you can also start an update or reboot) for displaying its current IP.

Furthermore one should be able to switch to a promt by plugging in a keybord and press strg+alt+ “an F key”

Regards,
Martin


#3

@Janr

The easiest way is to start the MOD-UI engine and after that point your browser to http:zynthian.local:8888 (or the IP address of the Zynthian and port 8888).

Regards, Holger


#4

@C0d3man

I tried it several times but it never succeeded.
I had to start manually the server. Otherwise it wouldn’t start.

Maybe because my hardware isn’t ready yet and i want to experiment and understand the software before the hardware is finished.

regards,
Jan


#5

I installed from scratch today. After 3 updates, I created the Mod-UI Layer in the zynthian-ui and I could access :8888 from my browser without any further ssh actions.


#6

@mheidt,

Did you access the browser with the Zynthian connected or without ?

I’m experimenting only with a Raspberry Pi.
The Zynthian itself isn’t ready yet.

regards,
Jan


#7

@Janr

What is “zynthian” for you? the software doesn’t work, if you don’t have a soundcard connected.
I am not sure, how it behaves if the controller board is not found.

So yes, I was referring to a correctly connected zynthian, that I connected to my local net via WIFI.


#8

So helping to get it running is really difficult and time consuming for us - sorry.

Regards, Holger


#9

hello!

I think its since the last update that I cannot access the pedalboard in my browser anymore.
The Terminal shows me:

Summary

root@zynthian:/zynthian/zynthian-sw# mod-ui/server.py
Using HMI => False
cc start socket missing
jack client activated

When I tried to start mod-ui manually first then the terminal showed me this:

Summary

root@zynthian:~# systemctl start mod-ui
root@zynthian:~# cd /zynthian/zynthian-sw/mod-ui
root@zynthian:/zynthian/zynthian-sw/mod-ui# ./server.py
Using HMI => False
cc start socket missing
Traceback (most recent call last):
File “./server.py”, line 27, in
webserver.run()
File “/zynthian/zynthian-sw/mod-ui/mod/webserver.py”, line 1539, in run
prepare()
File “/zynthian/zynthian-sw/mod-ui/mod/webserver.py”, line 1515, in prepare
application.listen(DEVICE_WEBSERVER_PORT, address=“0.0.0.0”)
File “/usr/local/lib/python3.4/dist-packages/tornado/web.py”, line 1705, in listen
server.listen(port, address)
File “/usr/local/lib/python3.4/dist-packages/tornado/tcpserver.py”, line 125, in listen
sockets = bind_sockets(port, address=address)
File “/usr/local/lib/python3.4/dist-packages/tornado/netutil.py”, line 145, in bind_sockets
sock.bind(sockaddr)
OSError: [Errno 98] Address already in use
root@zynthian:/zynthian/zynthian-sw/mod-ui#