I'm a Newbe exploring the Zynthian with experimental hardware

Hi all, I’m a newbe joining the community and this is my first posting, so excuse me. I’ve ordered a v4 kit and while waiting for it to arrive I thought I’m setup an experimental rig comprising of a ‘headmess’ Raspberry Pi3 and an AudioQuest Cobalt usb DAC and an AKAI MPK mini II controller?

Q1. Has anyone tried an AudioQuest Cobalt DAC?
Q2. I’ve looked at the remote ‘admin web console’ from my MAC, but can’t see a way to set a soundfont to play? Do I need access to the actual Pi3 console in order to set up a soundfont? Or do I need a small touch HDMI attached first (or even a normal HDMI monitor?).

Please advise!!

image
Not that I’m aware of. That isn’t what I was expecting when I went to find a picture… :smiley:

Yes. The zynth GUI is considered a performance environment and is a required component of the system. There is a lot of functionality there that isn’t available anywhere else.

But it’s not all totally awful news . . .

You can use vnc pretty easily to get at the gui from a connected device wiyth a vnc client on it …


Explains enough to get you going . . .

Obviously amongst zynth literati this is viewed with deep contempt ( Uses Power,clutters up your network, uses too many ravens and not enough crows the normal sort of stuff. . .) but I remember the days when using USB was enough to get you thrown from the battlements so these things do change. . .

Oh by the way we will be needing a :face_with_monocle:. Its a little thing and it’s something shiny to wave for the children to make up for the lack of pressies this year!

You could just plug in a HDMI screen to set up your layers and save as default then go back to headless.

Many thanks for both of your tips, maybe I should have tried Riban’s tip first as it would have been easier (if it wasn’t for the fact the TV’s on another floor, in the back of the car, in a back room where the boys are!). I went for the vnc route and now that’s working I see


So, before I re-image and start from scratch, I thought I’d nudge you once more :relaxed:

Great news is my real Zynthian v4 arrives next week so the above will scrapped, just looking to entertain myself before then.

Regards

Colin

Point a browser at 192.168.5.181 and see if you see the webconf screen…

login ( the password should be raspberry, which you can and sholud change in the webconf security page) and in interface sction chhose UI-log…

this should tell you what is going on…

Login on with ssh is the next stage if this doesnt help or you cant access webconf…

Wow, finally I’m up and running! Managed to get my Zynthian prototype build-up and working just a day before my v4.1 kit order arrived. I got over the this was achieved by using the “ERROR” IP Addr" see earlier. I originally used, 2020-09-05-zynthianos-buster-lite-armhf-1.0.0 build and later tried 2020-09-05-zynthianos-buster-lite-armhf-1.0.0 2 gave the same result splash screen message! I’ll remind you I was using Pi3b with customsettings and it’s HDMI to and external monitor. Fiddled with many setting and in then end I tried a release candidate or al least a daily build image (2020-11-22-zynthianos-buster-lite-armhf-1.0.0), that did the trick :slight_smile:

By the way, thought I’d try another hardware platform during my diagnosis and dropped the SDcard into my Pi 400 with 4Gb(Pi4 with a keyboard) and that had an interesting result? with build ‘2020-09-05-zynthianos-buster-lite-armhf-1.0.0’ it would boot for a second and automatically switch off? 2020-09-05-zynthianos-buster-lite-armhf-1.0.0 02 was the same. 2020-11-22-zynthianos-buster-lite-armhf-1.0.0 would boot and remain on but to a blank screen, not even a flashing curser! Anyway, put the same 2020-11-22-zynthianos-buster-lite-armhf-1.0.0 into my new ‘shiny’ v4.1 hardware which as you know is a Pi 4(with 4Gb) and Bingo, works, it boots and that’s what I’m using in my rig. Just thought I’d mention it in case one of the developers casts an eye. I’m not intending to use my Pi 400, but thought it interesting.

That’s it, thanks

Regards

Colinp

1 Like