Issues switching to Oram-Bookworm-64 bit branch

I changed the thread title to reflect what this topic has become…

I’m trying to switch to the Oram branch, I tried it from my running Zynthian and from a freshly burned sd card of

I switch all the repos in webconf to Oram and then Update Software and let it finish with no errors that I see. In either case, when I reboot, I get the Zynthian big red error screen with IP address and Exit:1 at the top.

I tried ssh to the IP address and get
$ ssh
ssh: connect to host port 22: No route to host

Any ideas to fix or troubleshoot?

We fixed some issues a couple of hours ago. You could try another update. If it’s still broken then post since logs.

Hi @tunagenes !
Why not testing with the bookworm aarch64 image?
I’m not testing in arm32 oram anymore. I’m focused in bookworm and testing every change in 2 images is too much.
I will check updates in arm32 from time to time, but the goal is moving to bookworm aarch64 ASAP. Hopefully next week we will have a fully working bookworm image.



Mainly because I just got an Akai APC Key25 mk2 and I wanted to try out the “driver” that @oscaracena wrote for it - and I did - it’s very impressive, along with the underlying new support for drivers! It did not work immediately with bookworm, but I understand you may not be done yet.

It’s very exciting to hear your plans to focus on Zynthian-Bookworm. I did download-install the image and run Update. A question - below is a copy-paste of the webconf dashboard. Notice that under SOFTWARE zynthian-sys is set to chainman_bookworm branch - is that the way we should leave it or switch to oram branch?

I also thought it was interesting that the HTML links came across - at least they’re there in my preview as I’m typing this. I’m not sure what we could do with that, presumably someone could click on them and if they have a Zynthian running it would respond?!


Raspberry Pi 4 Model B Rev 1.4
Audio: V5 ADAC
Display: MIPI DSI 800x480 (inverted)
Wiring: V5
I2C: MCP23017@0x20, MCP23017@0x21
Profile: v5


Debian GNU/Linux 12 (bookworm)
Build Date: 2024-02-01
Memory: 6% (491M/7811M)
SD Card: 52% (15G/29G)
Temperature: 40.9ºC
Overclock: Maximum


Tuning: 440 Hz
Master Channel: Off
Preload Presets: On
ZS3 (SubSnapShots): On
Power Save: 10 minutes
Audio Levels on Snapshots: On


zyncoder: oram (9ea5d33)
zynthian-ui: oram (f2d7b4c)
zynthian-sys: chainman_bookworm (23c689f)
zynthian-data: oram (64c5f91)
zynthian-webconf: oram (37d9e55)


Snapshots: 13
User Presets: 22
User Soundfonts: 0
Audio Captures: 0
MIDI Captures: 0


Hostname: zynthian
Wifi: Off
VNC: Off
MIDI Services:

1 Like

I did try again and it worked! Thank you!

Great to hear it works for someone else than me! :clap: :clap: :slight_smile: What “version” (aka commit) did you try? Did you try the sequencer support?

EDIT Also, you said it didn’t work immediately with bookworm, what changes did you do to make it work?

Hi @oscaracena, and Thank you! - I don’t know what version-commit I used - whatever came with the Oram branch. I only tried the ‘device’ support, although I will try the other modes.

I haven’t gotten it working with bookworm - I think it will be included as @jofemodo completes Zynthian bookworm.

1 Like

Good to know! I’ll try to do a PR as soon as possible, with the latest changes :slightly_smiling_face:

Perhaps the device ID is different in bookworm. My launchpad mini mk3 changed its name and I had to add a new id alias to the driver.
Please, @tunagenes , copy the name you see in the device list for your APC


Perhaps, I think I know what to do, but I haven’t been able to get to a terminal on Oram Bookworm - when I try via WebConf I get 500 Internal Server Error. When I ssh by IP address I get No Route To Host, when I try ssh to zynthian.local I get a whole screen full of messages starting with Possible DNS spoofing or some such. I’ll try it on another system…

I have already captured the issue with webconf terminal.
I am able to ssh via IP.
Because the new image will have different ssh signature and your remote host (e.g. laptop) stores this signature for each host it connects to, you have to clear the signature from the remote host’s ssh config. My ssh client gave me a warning that included the command to remove the offending signature but if I don’t see that message then I either manually edit ~/.ssh/known_hosts or remove that file completely. The latter just means accepting authentication checks for each ssh server I connect to again.

[Edit] The command to clear the ssh reference is ssh-keygen -f "/home/user/.ssh/known_hosts" -R "hostname" (replace user and hostname).

1 Like

Hi @jofemodo - I asked this 4 days ago and I never saw an answer, I’d like to know which repo you’d like me to use for testing - zynthian-sys- chainman_bookworm or oram. The copy-paste below is what the image set and I don’t know if I should leave it like that or set zynthian-sys to oram like the other repos.

zyncoder: oram (9ea5d33)
zynthian-ui: oram (24a24e4)
zynthian-sys: chainman_bookworm (b653b15)
zynthian-data: oram (64c5f91)
zynthian-webconf: oram (a5442c1)

Hi @tunagenes!

The answer was probably delayed by effort to resolve differences between 32/64-bit. We made the decision (yesterday I think) to drop 32-bit support from Oram so I expect that these branches will be merged. (@jofemodo - can that be done today?)

So the answer to your question at this point in time is that you should use chainman_bookworm if you are using the 64-bit image and oram if you are using the 32-bit image. This is likely to change very soon.


Got it - Thank you!


Does this answer the question? This is from recently updated 64 bit Oram:
(venv) root@zynthian:~# amidi -l
Dir Device Name
IO hw:1,0,0 APC Key 25 mk2 APC Key 25 mk2 K
IO hw:1,0,1 APC Key 25 mk2 APC Key 25 mk2 C
IO hw:3,0 f_midi
(venv) root@zynthian:~#

I confirm these names as they are the same in my desktop (Pop_OS!/Ubuntu). I presume K is for Keybed and C for Control, or something like that.

It should be working now. If not, please, tell me the name you see in the MIDI device list from the zynthian-ui.


This is the (ridiculous) effect of the change to the kernel. It is the device name “APC Key 25 mk2” plus a space plus the port / enpoint name “APC Key 25 mk2 C…” (probably “…Controller”) but this is truncated to 31 characters to fit the 32 byte buffer available for alsa names. I am amazed (and rather annoyed) that this issue has arisen and persists after two years. I haven’t found the right target for my angst yet and maybe by time I do, I will have clamed enough to provide a rational bug report / feature requests. (At the moment it would just be a rant about apparently daft decisions!)

The device driver for the controls would have the id “APC Key 25 mk2 IN 2” (if the keyboard was the first port and controls the second port). We now take the device name and append “IN”/“OUT” and the port number (1, 2, etc). The full URI actually includes “USB:x.y.z/” at the start which identifies the physical USB port to which it is attached. Ths is stripped for the device drivers and if Zynthian is configured to, it is ignored for ZS3 loading, i.e. the USB MIDI device can be plugged to any port.


It works! Thanks @jofemodo @riban @oscaracena !