It's time for Buster RC-2. Testers Needed!

Could you be more specific about the problems you found?

Ups! Regarding 2020-05-14, the auto-delete system probably get ride of it. It deletes SD-images older than a week if they are not marked as RC.

But if we don’t find another working SD image, @wyleu can upload his copy to the server :wink:


of course I can be specific:

start with a new image: display error
Followed by about 5 minutes of black screen
Then very slowly fading in and out - zynthian - ERROR IP:
Zynthian directly connected to the router via LAN.
Display: ERROR IP:
webconf does not work over zynthian.local or over IP
continue via console:

Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
Please contact your system administrator.
Add correct host key in /home/“user”/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /home/“user”/.ssh/known_hosts:1
You can use following command to remove the offending key:
ssh-keygen -R -f /home/“user”/.ssh/known_hosts
ECDSA host key for has changed and you have requested strict checking.
Host key verification failed.

ssh-keygen -R -f /home/“user”/.ssh/known_hosts

no further connection via browser - continue via console

display console: Update complete -
but still flashing display - error: IP

in console: reboot

on startup: flashing display - error: IP

and again:
ssh-keygen -R zynthian.local -f /home/“user”/.ssh/known_hosts

webconf now possible in firefox
once angain Software Update - now with firefox

reboot -
on startup: again: flashing display - error: IP

->given up

Hi @spurkopf,

Please, could you send the webconf log?
Simply type:

journalctl -u zynthian-webconf -f 

And try to access from the browser. Then copy/paste the output from the console. With this i could figure where the problem is and try to solve it for the next SD image builds.


No sorry, 2020_05_22 is already deleted. I have a copy of the 2020_05_17 UI log - I’m uploading it. But why mess with it, wouldn’t it be easier if you could say - this image worked for me - please test it?
Zynthian_17052020Ui_log.txt (31.2 KB)

testing 2020_05_16:

  • o.k. this time webconf works out of the box
  • again displaying ERROR
  • but this time it detected a V3PRO
    while 2020_05_22 and 2020_05_17 detected Raspberry Pi 3 Model B Plus Rev 1.3
  • changed to Raspberry Pi 3 Model B Plus Rev 1.3 and reboot, now ZynScreen ist working - but no encoders
  • changed to custom kit and Mcp23017 Encoders - now they are working too
  • switching of single mode, activating midi clock internal and setup wifi
    Now it should all working. :sweat:

3 posts were split to a new topic: Qmidinet feedback

Zynthian doesn’t detect hardware, apart from the RBPi. SD images are pre-configured for a given hardware combination, depending on the image date. The latest ones are pre-configured for “Kit V3 - Pro”. What is your kit version @spurkopf?

According to your bill, I have:

  • Aluminum Case Kit v2
  • 4 x Controller Module Kit v2
  • All-In-One Module Kit
  • Ribbon Bus cable v2
  • Wiring Kit v2
  • RaspBerry Pi 3 B+ (computer board)
  • HifiBerry DAC+ Kit (soundcard)
  • OzzMaker PiScreen 3.5’ (touchscreen)

Build from today(2020-05-23) is no candidate.

@jofemodo, webconf doesn’t start…mutagen

WARNING:zynthian_gui_config: No Display!
Traceback (most recent call last):
File “./”, line 42, in
from lib.ui_keybind_handler import UiKeybindHandler
File “/home/pi/zynthian-webconf/lib/”, line 31, in
from zyngui.zynthian_gui_keybinding import zynthian_gui_keybinding
File “/zynthian/zynthian-ui/zyngui/”, line 53, in
from zyngui.zynthian_gui_audio_recorder import zynthian_gui_audio_recorder
File “/zynthian/zynthian-ui/zyngui/”, line 29, in
import mutagen
ModuleNotFoundError: No module named ‘mutagen’

ah @jofemodo and I didn’t check…Pianoteq…there is a 6.7.1
Is the free trial updated already?

OK! I found the problem with mutagen and the SD build script:

# Install Mutagen (when available, use pip3 install)

I just launched a new build for today (2020-05-24). It will finish in about 4 hours, about 21:00.


@jofemodo Were you typing too fast when you wrote that?
:face_with_raised_eyebrow: :grin: :rofl:


Hi José,
is that the one we should test in priority ?

Nope, that’s from yesterday and still has the mutagen bug (tested this morning)
[In reply to “
is that the one we should test in priority ?”, hit the wrong reply button :frowning: ]

Ok, thank you.
So far, I think running


should solve the problem.
So except that “mutagen” bug, this version should be like the next one.

I will post a download link when a “good” candidate is ready. It should be in the next hours … :wink:

1 Like

If of interest, I tried to install on official Kit V2. Initial boot showed error screen with IP adress. Webconf not working, but could ssh into zynthian. Then did webconf now working, zynthian boots regularly.
Then I tried to activate pianoteq stage, uploaded the pianoteq 7z binary. In the webconf screen, I tried to enter my license key, but got the error message (in webconf browser output): Pianoteq Action Failed: Command ‘/zynthian/zynthian-sw/pianoteq6/pianoteq --activate MY-LICENSE’ returned non-zero exit status 2. (I replaced actual license key for reporting). So I remembered the old way of activating: start pianoteq layer with a running ssh -X connection to zynthian. Then a window of pianoteq gui appears on the computer where activation info can be entered. So far, everything works fine.
But have mixer settings / audio been changed? Whenever I play some key, there is an accompanying noise that then fades out. Seems like the audio channel is opened (noisy) when active and then muted again. Tried to record the effect with zynthians audio recorder, and the effect is there when played back on the zynthian. But too low volume when played back on the computer so I cannot really demonstrate it. But it’s not the auto mute feature (which is turned off). It’s different. noise is of constant level, and it affects any engine.
I have hifiberry dac+adc.

–> edit: regarding the noise, I’ll try to investigate this: A weird noise is driving me mad [SOLVED]
My hardware hasn’t changed and the noise wasn’t there with previous official

ok, I’ve tested

  1. black screen on first boot. webconf was stuck
  2. through ssh, run
    => webconf start
  3. through webconf, configure my hardware:
  • kit: custom
  • audio: behringer umc404hd (I’ve got the 204HD, but I know it’s okay)
  • display: waveshare 5inch hdmi + GPIO
  • wiring: dummies
  1. reboot => ui start, but no touch (maybe there’s something broken on my display, I’ve got to test it tomorrow with a clean raspbian distro), ads7846 module is loaded btw
  2. plug an usb mouse, create a ZY layer on channel 1 and plug an hardware midi step-seq, then create a simple pattern => through webconf UI, I see midi notes coming in but there is no sound output from the usb interface :thinking:
  3. check alsamixer settings: ok (100%)!
  4. check the usb audio interface on my pc => ok (hopefully !!!)

Note also that I wasn’t able, using the mouse to get out from the ZY instrument screen

  1. Ok, reboot, and let’s try with an other instrument (fluidsynth/TimGM6mb/piano 1) => yes :smiley:
  2. add a new layer (amsynth) on channel 2 => yes :smiley: yes :smiley:
  3. try step seq: ok but I didn’t find the way to adjust note length and note level with the mouse


  • still that problem with mutagen
  • strange bug with ZynAddSubFx
  • got to test more instruments
  • got to test mod-ui, touchosc, qmidinet
  • got to check the touch function on my display
  • but tomorrow, cause now I got to go to bed :sleeping:

This is the image we have to test:

I’ve fixed 2 errors in the setup script and it should work … i hope!
I will test it tomorrow, but if some of you want to try now, please, do it :wink:


Curious … i fixed the error and it should be working …
At what time did you download the SD image from the server?