Jackd options not always right


#1

Hello,

I noticed that the jackd process is sometimes starting with the wrong options:

root@zynthian:~# ps aux | grep jackd
root (…) 0:00 /usr/bin/jackd -T -ndefault -T -d alsa

Instead, we should have the options set in the jack2.service systemd config (/usr/bin/jackd -P 70 -t 2000 -s -d alsa -d hw:0 -r 44100 -p 256 -n 2 -X raw)
The sample rate corresponding to default is 48000khz.
It’s not happening all the times but I saw it quite often.

I found out that this happens when the jack2 service fails to start. To solve the issue, I added a “Restart=on-failure” option for the service.
This is a quick and dirty fix but since then, jackd gets initialised with the correct options.

I use the last version of the Zynthian software but this problem is not very new.
Maybe this behavior happens only to me as I cannot stop myself from tweaking linux platforms :slight_smile: . Can you guys please check on yours ?

Cheers,
Claude


#2

Nice! I will test your trick and if it works OK, modify the service file on the repo :wink:

Thanks!


#3

OK! The “Restart” option has been added to the jackd systemd service unit.

Thanks!