Latest zynthianos on kit v3

I recently tried to update my kit v3 software and now zynthian does not run. I would like to reinstall from the latest zynthian os image. Is it compatible with my v3 zynthian kit?

It is supposed to be. How did you try to upgrade? If you tried to update ‘online’ would it be possible for you to try a fresh install on an SD-Card?

If you’re experiencing problems, if you could provide more info on how it’s failing, a screenshot from webconf if you’re getting that far, logs if appropriate, that would help with troubleshooting the problem.


Yes, I’m planning a fresh install on an SD-Card. I wanted to know if that’s expected to work, so you answered my question. Thanks! Crossing my fingers that it works!

1 Like

It should work and autodetect your v3 kit. Zynthian Software - ZynthianWiki

Thanks for that! It was stuck at the splash screen, but then thanks to that link I saw that I was supposed to configure the hardware from webconf. It looks like it thought this was v4. I changed it to v3, but the reboot didn’t seem to work, so I shut it down from the console shutdown -p now. After powering back up the UI is coming up correctly.


There are BASH helper functions called poweroff and reboot that perform the shutdown commands as expected. I am starting to forget the parameters for shutdown having used poweroff and reboot so much fo a few years. (shutdown -h now and shutdown -r now have been etched into my brain though!)


It’s been a while since I have been using my Zynthian. I bought it for use with my wife’s Alesis Vortex keytar. She has since more or less permanently stopped using it, but now I’m playing it with an ensemble. It’s wonderful to see that the Zynthian is still in development and going strong. Also, I very much appreciate the backwards compatibility with older kits. As a software engineer I know that maintaining backwards compatibility can be tricky and expensive so kudos to jofemodo and all Zynthian developers. Making a new product is one thing, but supporting it well is quite another.


Damn, I’ve missed that. uhhh