Locked out after changing password

I was in the middle of trying to work out how to inspect the file system on my freshly assembled Zynthian, when I decided to change the webconf password. I’m pretty sure I remember what password I used, and I had to enter enter it twice (I’m assuming they are checked against each other) so a typo is unlikely to be the issue. In addition, I let the Chrome password manager remember the password, and it agrees with my memory of which password I used. I am however getting an “Incorrect Password” error whenever I try to log in. “Rasberry” does not work either. Before I wipe the device and re-flash the memory, I thought I’d check if there was a less nuclear way to reset the password?

It would be raspberry. But why should it have the original? Did you see the password in the password manager? Did you try a different browser?

It’s really strange. AFAIK, the password changing works perfectly … and we did a good testing for sure!! :wink:

  • Did you include some really strange character in your password?
  • Have you tried to clean your cookies or use a private browser window, etc?

Regards,

Hi tstex,

I got a very similar problem last month with my Zynthian. My computer became suddenly unable to connect to the Zynthian webconf, claiming that password was incorrect (however, I did not change it before). Closing and restarting my browser did nothing.

The problem disappeared after a full reboot of the computer AND the Zynthian (full reboot = cold start, not just “restart”)

If you still have the problem, I would recommend to try to change your browser (try with Firefox). Chrome keeps a lot of things in memory to “optimize your navigation experience” (another way to “tracking everything you do” :stuck_out_tongue:), but I already saw Chrome being screwed in its password management and sending a password from its configuration file rather the one that you type

2 Likes

I finally found time to re-flash the Micro SD card. This did not seem to make things any better. I still am not able to login via webconf. actually remember having trouble logging in from webconf the first time I got the Zynthian running, and being somewhat unsure what I did to get in, but I just bookmarked it, and saved the password in the password manager in chrome.

I have also tried accessing the zynthian via putty using the web page below with some variations. I have two network cards in this pc, and I can see my Zynthian’s IP address in the arp output of one of them. Putty also does not see the root /rasberry or the pi / rasberry user / password combinations.

Is there some sure fire way to reset and re-access the zynthian?

I don’t know idf its been suggested but try clearing zynthian cookies from the browser.
That has worked for me in the past.

Tried raspberry instead of rasberry?

What SD image did you use?

How do you delete an individual cookie in chrome? Apparently they’re all in an sqlite database file? Did you deleted the whole thing? ( C:\Users\adl\AppData\Local\Google\Chrome\User Data\Default\Cookies )

In any case I’ve tried Chrome and Firefox without luck, so it’s probably not a cookie, and I’m wondering if Windows is the issue?

Dammit! That was it. Thankyou!!

4 Likes

In chrome it’s now part of the developer tools…

:man_facepalming:
:grin::grin:

:face_with_monocle:

1 Like

Ohhh! Yessss … a mistake like this deserves a good sound sample :face_with_monocle:
:laughing::laughing:

1 Like