MIDI-FX chain

Hi @zynthianers!

I’ve been working a little bit in adding a MIDI-FX chain to Zynthian. It’s an old “TODO” task and recently “someone” opened a new “feature request” in the tracking system:

After fighting with some dragons in one of the darkest and dangerous dungeons of zynthian core, i can say that i almost finished … although some details are pending and, of course, a few bugs that you, i hope kindly, will help me to hunt …

Those of you wanting to test this new feature, simply select the “midi-chain” branch for UI’s repository. You can use the webconf for that.

Ahhh!, don’t forget to “enable” some MIDI tool plugin from the webconf’s LV2-plugins panel :wink:



Of course … a :face_with_monocle: is mandatory in these cases, so …

Simply a little of noise using a single layer like that:

  • ZynAddSubFX
    • MIDI-FX: MIDI-chord -> MIDI Arpeggiator
    • Audio-FX: MDA Degrade



Thank You for the new features! I was able to create layers controlled by an external controller. I used the “Multi Channel” mode in the Zythian settings, channel cloning and the “Midi Event Filter” midi-fx in each subordinate channels.

There is a problems…

After removing the layer instrument that used Midi-fx insert, the midi-fx itself remains on the layer.
You can only delete the layer using the “Remove all Layers” command, other doesn’t work.

Of two or more identical loaded engines, only the one loaded last sounds … I checked on linuxsampler and fluidsynth…


1 Like

Hi @Roma!

Thanks for testing and reporting. I’ve solved the bugs (i hope!!) so you can update and test again.


1 Like

Thank you, both problems are solved!!

I found another bug… but maybe I just didn’t understand enough about MIDI routing…

I used the “Multi Channel” mode in the Zythian settings, channel cloning and the “Midi Event Filter” midi-fx in each subordinate channels.
When I activate knob “Block Notes” in the corresponding midi-plugin in channel 3, the lock is applied to all channels where the "midi event filter"is used.


another bug…

“MIDI-FX Layer” cannot be removed with the “remove layer” command…

Here are some bugs I found so far.

  1. Pd patches quit working correctly. Grids and generative relaxing play but don’t respond to controls. All of the other Pd patches produce no sound at all.
  2. Mod UI is erratic, Loads okay sometimes and other times freezes.

When I change back to Master everything works correctly again.

Could you give more details about the engine you are using for each layer?


Linuxsampler, Fluidsynth…

It’s solved now.

1 Like

Hi @ronsum!

I think it’s solved now. Could you update and test?


Hi @jofemodo,

Yes, you fixed it! The option to “Add MIDI-FX” is available for Synth Layers but not for Special Layers. I suppose that is the way it is suppose to be and not another bug. I’ll keep testing later and let you know how it goes. I’m curious if you still have plans to add MIDI routing at some point. It would be very handy to be able to route midi notes from PD to other synth engines without having to use Patchage. Anyway, the MIDI-FX feature is an interesting and fun tool. Thank you for all of your efforts.

1 Like

I’m not seeing this plugin in the LV2 list. Do you have any idea why that is?

Have you enabled it in webconf?
Have you regenerated the list of plugins in webconf?

Just to be clear, I didn’t see it in the webconf. Otherwise I wouldn’t have complained! :slightly_smiling_face: However…

…I have not done this yet. Let me try that.

It’s been included in the very last SD images, but an update should get it installed. If not, you can try:




It was not enabled for Special layers yet … but now it’s. Simply update and enjoy!
Regarding MIDI routing … i’m working on it!



Great! Once MIDI routing is working I’ll put some patches together to put it to use. I just tried out the MIDI-FX with Special layers and it seems to be working well.

A little :face_with_monocle:. Good night!

  • Layer 1: ZynAddSubFX Collection/Soft Hammer
    => Chord => Arpeggiator
    => Clone to 2
  • Layer 2: Dexed DCDCollection/09_ELEC_VANG
    => Chord

And 2 fingers :wink:



Wow. Someone’s staying up late!!! :sleeping: