MIDI-IN connector issues [solved]


I built a Zynthian Box with official Zynthian kit. Everything is working exept midi din.
I double checked connections and tried inverting the two wires but nothing is working …

Do someone experienced issues with midi din in?

Hi @Djeremaille!

It should work. I only can suggest that re-check the wiring, putting attetion to 2in1 to GPIO connection. Also, check the opto-coupler and diode orientation, correct soldering, etc.

Are you using Gorgona SD image?


Yes I,m using Gorgona.

I will triple check…

Actually my wiring is like that:

So I triple checked and now it’s working!
…I’ve done nothing…


Great! Sometimes i think gremlins exists :wink:
Hi! Have you printed the 3D-printer box? Please, send some photos. I’m very curious about the result!


1 Like

I will post my pictures this morning!

Hello. I’m using my Zynthian for a several months, but MIDI-IN is still doesn’t work.

So, when zynth have been disassembled at the very beginning it returned logo with “error” when runned - I’ve checked 2in1 board - one of chips was hot - I’ve checked wires - 6pin-connector was wired in reverse order - I’ve rewired and Zynth works.

But, MIDI-IN doesn’t work.

Is any way to check 2in1 board? I can use external RX-TX device to send or receive commands using serial port, or, maybe, some script exists for checking, or I can check it using multimeter?

and [topic offtop] second question: how to access shell when hdmi display connected? Before gorgona-image it was accessible, but not now.

Hi @quadrica!

  • Probably you have try this, but … have you checked if the MIDI connector pins are reversed?
  • Have you checked that red wire of the 6-pin-row connector (pin 2) is connected to the RX pin (pin 10) in the RBPi GPIO?

For properly testing the 2in1 MIDI-IN circuit you will need a MIDI source (keyboard) and some kind of oscilloscope. You could try to make a software test, but if MIDI-IN doesn’t work with a fresh Gorgona image, it’s quite clear that it’s not a software problem.

A multimeter can be helpful for doing a quick CC test. You can check if there is a CC between connector pins, but it’s difficult to check if the optocoupler is OK.

I recommend you use a small metal brush to clean the surface of the PCB, and after that, do a visual inspection with a magnifying glass. If possible, send a photo.

Ups! I’ve never tried this with Gorgona. I always use SSH :wink: Let me try …

Kind Regards!


I’ve checked wires - it was ok.

Now I’m experimenting with developing of midi interface for my live set-up, and, I decided to create simple arduino-based device, which can send midi-messages using TX port. I’ve used also schema of wiring because of voltage differencies between boards:

It works!

After this little success I’ve decided to check the system using optocoupler schema:

I’ve developed it using prototype board, fortunately, I had all necessary components.

It works too!
I’ve placed this board inside Zynthian (temporary).

I suppose - optocoupler in 2in1 board is dead. Next time I will try to desolder it and exchange.

Thank you for instructions.

1 Like

When I use the Gorgona image, I find that tty3 (or maybe tty2??) is occupied by the Zynthian UI with no window manager or desktop.

@quadrica No matter, this is why Linux has multiple Ttys–if you are using HDMI monitor and talking about shell, I assume you do NOT mean ssh. I assume you have a keyboard and mouse connected to your RPi… right?

If so, you can press Ctrl+Alt+F1 to get to tty1, Ctrl+Alt+F2 for tty2, and so on. Zynthian UI loads on tty3–just keep trying combinations above until you get a login prompt!

@quadrica I also just realized: if you want to use a desktop manager with your HDMI-connected monitor, you can install Openbox, apt-get install -y --force-yes openbox and then run startx to run it on that display once you’re at a prompt/shell. I use this and then launch the Zynthian UI inside a managed window for dev purposes. May not be what you’re looking for, but thought I would offer it up.

Thank you! I will try at evening.

hi, i also get a problem using the midi in, down have to enable something after a clean instal of Zynthian to make the midi din working? I already build midi in for Arduino so I had already checked my wiring and adapted the resistor but I can t debug my problem I use the exactly same schematic as in the last posts 5v to pin 02 on pi gnd on pin 06 and rx to pin 10 I already tried inverting din socket and also diode easyli cause I m on a breadboard, this interface work on my teensy like this so I think the problem is in the configuration and stil nothing, if someone has an idea it would be nice!