Midi-in routing broken? solved!

Has anyone noticed? I wanted to ask here before I write a bug report. The midi-in signal seems to disappear somewhere in the zynthian. The “m” display works, but the signal does not reach the synths. The control from the midi player to the synths works.

I’ve been having strange effects in this area.

Have you played with the MIDI log?

Yes, I´ve tried. I have input in Midi-In-tab, but nowhere else.

can you use the ssh console to run patchage…?

This is strange, it works again and I was able to reproduce the error by switching sounds on the surge plugin, but this no longer occurs. So I’ll sign this off as done until further notice.

Are you using the very last version of Zynthian UI? Last week I fixed a bug that could be related …


When the error occurred I used a fresh installation of:

after software update. To check against it, I tried a SD-card that had an insignificantly older OS, probably without doing an update beforehand. The error also occurred here, and remained despite several reboots and then the following update. Today it worked again at some point. I can’t explain it to myself, I hope the hardware is okay and the error doesn’t come back.

1 Like