Midi-ox & DUOPIANO

Anyone familiar with getting MIDI Ox on windows 10 to recognise USB MIDI devices connected to it?

Well one of them seems to work!

1 Like

Yes, one of them seems to…

I have used midiOX a couple of couples of couples of times, on windows 95, 96, 97, NT, 7 and 10… those people from Microsoft pretend being the leader in informatix, but they even don’t know anything about decimal numeration…
That’s probably why they limit themselves to binary…
But most of the times I only used it to monitor midi outputs from external keyboard…
Don’t know if I can help…

1 Like

I’ve managed enough to prove the point…

Ok as I understand it a Class Compliant MIDI port should just crop up on a host as just that a MIDI port.

I’ve connected the DUOPIANO and a AKAI MPK mini to a xubuntu laptop : …

The akai plays to asqdump but the dopian doesn’t.

Igf however I use MIDI OX I get function after I open and select the GENERAL option in the midiox devices window. ( I’ll populate the example from the windows machine). Indeed I can run ipmidi (nerds.de) and get the DUOPIANO playing a zynthian via MIDI-OX…

All a bit confusing anyone anyone spot the obvious mistake I’ve missed in all ths?

I’ll get boy wonder to render up a little playing on the piano for an example ( Piano patch recommendations…?)

It seems to require the opening of the device as an input to make it work . . .

No repsonse to simply monitoring GENERAL as an input but add the MPK as an input and select GENERAL as an output and it all appears to spring to life…

Can we impersonate this behaviour in a zynthian driver…?

Much head scratching at wyleu towers.

Also patchage seems to be a right pain to install on a vanilla xubuntu example which I don’t remember it being…

1 Like

Hi @wyleu. Sorry - I don’t quite follow you. I think this is what you are saying but please validate / correct:

  • DuoPiano appears to ALSA as an input and output device, both called “GENERAL”
  • Connecting ALSA source “GENERAL” to any(?) ALSA destination, play DuoPiano: no output from destination
  • Connecting an ALSA source to destination “GENERAL” and connecting ALSA source “GENERAL” to an ALSA destination, play DuoPiano: successful output from destination

If this is the case then feature request 263 should help. In the meantime you could add a service to automatically route something to the DuoPiano - this could by written in your favourite Python and loop, checking for the route and adding if missing.

That sounds about right. The duopiano is visible via a connect but doesn’t route to aseqdump. Which is my normal sanity check. It appears that midiox opening the duopiano as an output device kicks it into life. I’m talking to their tech end and I will wait to see what they say.

Does it work if you manually route an alsa source to its input on the Zynthian?

That’s what I was trying to do but patchage proved to be a real pain to install . . . (Endless stream of libs to install that lead to other libs that you can’t find to install)
I’ve got a bit of real work to do today so I’ll try to get that done before getting back to it.

Patchage installs on Zynthian with apt install patchage. You can also use qjackctl or aconnect. The point is to route something (anything) to your ALSA GENERAL port on your Zynthian and see if your ALSA GENERAL source on your Zynthian starts working.

Ok, Pulled and moved to a zynthian-ceed.local and

It’s now working. :smiley:

I suspect the magic MIDI pixies that scamper round the farthest reach’s of Castle Zynthian have been playing perhaps…?
I notice the ticket you mention has been closed.

Now to see how repeatable it all is.

The DUOPIANO’s weaknesses…?
It’s power management.
It has it’s own battery supply ( Excellent idea) but it turns itself off after a time.
Not good for piano accompanying the 3rd song in a set.

And now Its gone again … :frowning:

Got patchage working. Normal problem forgot to run ssh as -X (D’oh) . . . :smiley:

And it’s back…
And now Its gone again … :frowning:

And now it’s back…
Trying to pin down the golden sequence…:smiley:

It does seem to genuinely rely on a separate MIDI source actually playing something to it…

OK A Sequence that works.

1/ Settings for MIDI Ports

2/ Restart Patchage and check General in MIDI section.

And then play on separately connected keyboard, to generate a MIDI event that will appear at Main_out to trigger GENERAL.

1 Like

Back on this and it seems confused. rtmidi recognises both a midi in and out port but fails on attempting to open them.
Given the devide is now no longer supported it’s all a bit hit and miss from here.
The zynthian MIDI libraries are as far as I can see hand coded in C so I can’t really advance to much there, but reading this thread I got it working in in the past. Have we altered anything down in the MIDI guys and what is fmidi port?

fmidi is the MIDI port of the Raspberry Pi in gadget mode, i.e. when it is connected to a host USB via its USB-C power socket.

Little bit of progress on this front.

A working test suite on a Duo-Piano initiation.