Mod-ui server interference with zynthian box controller knobs

If I am running a mod-ui and try to toggle through zynthian’s setup list to adjust different parameters, the cursor is jumping back to the first line on specific lines.
When I stop the mod-ui service (hence stopping the mod-ui server) then everything works fine in zynthian’s box interface (I can adjust all the parameters).

There seems to be some interference between the controller knob events of zynthian and the web server of the mod-ui.


Hi @gitnob!

I will take a look ASAP, OK?


Oh, that was a fast reply, thanks.
Yes absolutely OK.

@jofemodo I think I have a fix for you on that one. See:
I tested it on my brand-new Zynthian and it behaves much better.

1 Like

Yes, i see the thread on guthub … but i need some time to process this kind of requests …
Di you see the issue kanban? :wink:


That did the trick, @jwoillez, and implemented the patch on my zynthian box - perfect working now.

@jofemodo Indeed. That’s quite the list. I’m happy to help with MOD-UI for now. And for the little bug, let me know if you need anything else. Happy to give back.

@gitnob Great! And funny we stumbled upon the same issue at the same time. :slight_smile:

Hi @gitnob & @jwoillez!

I can’t see any problem … well, perhaps i don’t understad the problem because your description is “too short” … jeje! Perhaps you could give me a more detailed description of the problem so i can reproduce the problem …


Or perhaps the problem is solved. I just commited a bugfix for a controller problem that affected some engines … :wink:

@jofemodo Could you try using gx_duck_delay on the MOD-UI pedal board? This one has a port with a designation. This should trigger the issue (I hope).

It’s easy to explain. Use mod-ui as a layer in zynthian and try to toggle through the parameter settings of the lv2-plugins of a specific pedalboard.

This did not work because you could not reach the lower parameter settings because the selected line was set to line #1 of the parameter list every now and then.

@jwoillez’s patch helped and solved the issue (and obviously also his problem).

@jofemodo, which bugfix did you commit, to compare…

OK! I will try ASAP …

Sorry, i can’t understand. Please, an example is the best way of explaining a problem :wink:


OK! It’s merged … thanks for your contribution!! :+1:

1 Like