MOD-UI: snapshot switching


HI there…
when loading a snapshot with mod UI, if loading another with other engine, snapshot list selection doesn’t scroll over first one. if going back and reenter snapshot page (exiting and entering bank folder again it’s enogugh) , selection is possible again. With touchscreen i see i can select only first and last. with encoders it doesn’t move over first one.


Excuse me, @ivanmonterosso!

I don’t fully understand the problem. Could you give more details, or perhaps send a video?



Yes sure… here It is. Actually it happens with any other snapshot choice after the one with MOD inside, not only with other engines saved.

sorry i castrated video :smiley:

In my opinion the issue resides in page not switching to selected pedalboard controls… or better to say, remaining on snapshot page…these things happens naturally with other engines.

Happens in any snapshot type once recalled, if page is not switched out of snapshot section, whatever reason is.

and there is another issue over there:
to enter in pedalboard’ s control page, we must re-select It from list… forcing a reload of It…if you remember which is, between dozen or clones :grin:
but i think maybe this is more related to mod UI complexity… and didn’t report it, for now…
or i should to?


Hi @ivanmonterosso!

Can you check if this issue is solved with latest changes?



hi, for last changes you mean gorgona Next , or a simple update?
by now i tried and problem persist with mod snapshots.
the other thing is snapshot saved with mod engine causes zynthian hang… seems that mod ui isn’t recalled by zynthian snapshot…
But all this is not tried on gorgona edge.
i should prepare another card…

UPDATE— my mod ui doesn’t start at all… :frowning:


You should try with the last Gorgona Next … and update! :wink:



ok, installed gorgona next…
issue still exists.
And there are other things not apparently working (don’t know real reason):

after reloading fresh image, i restored my snapshots, and no one of them recalls the sounds correctly. (no matter if contains zyn, Fluidsynth, etc…)

About custom presets/sounds: (i saw a shining xmz :slight_smile: ) if xiz or xmz directory is filled, no My/ section appears on preset list.


have you tried a fresh installation without restoring anything. Did you restore using the webconf?


no, didn’t use webconf restore. i simply saved zss (and any other preset)
and uploaded with ssh as usual.
Installation is fresh.