Modulation and UI questions

Hello, I am also a first time poster and I also have a question about Zynthian UI, but a different question from @micahvdm; I didn’t want to clutter up the board with extra topics.

But thanks Micah for breaking the ice.

It seems like Zynthian is a really powerful and flexible platform - at a super reasonable price point. I admire how much free amazing stuff you provide. And the ability to assemble layers of generators and FX right in the machine. And the ability to include PD and Mod-UI layers. Wow.

I liked Seb’s tutorials, and I see that basic tweaking of some synth parameters is possible, but one thing I didn’t see, is how to add modulation, or create new presets, within the Zynthian box. Is that possible? Would you do it on a tablet or computer that was networked with the Zynthian?

I saw a “modulation” tab in Seb’s tutorials, but I don’t recall seeing him click on that. I didn’t see this topic addressed in the current documentation, but maybe i missed it.

This is kind of the opposite question to Micah’s, but they’re kind of related. To combine them: Can you remove aspects and options of menus that you don’t need, and can you also zoom in and patch and tweak and modulate when you do want to do that. Or is another machine needed. Or can you add a monitor and keyboard, and do that right on the Zynthian?

I know this is an open community based platform, and I realize that some features are still being developed. I appreciate what’s happening already; this is the main question that came up for me so far. Thanks in advance.


1 Like

Every synth engine has its own modulation parameters. There is not a common “modulation” module.
Anyway, i would like to integrate some kind of “automation” that allow to apply, for instance, a LFO to a parameter, etc. With the arrival of the MIDI-FX features, it shouldn’t be difficult to implement …


1 Like

@jofemodo thanks for reply! Take care.

You can do it in the MOD-UI with the qmidi* plugins I think.

1 Like

I just added the 3 QMidiArp plugins:

  • qmidiap-arp
  • qmidiap-lfo
  • qmidiap-seq

Simply update, click “Sarch for new presets & plugins” buttons from webconf’s LV2 panel, and enable the new plugins. from the MIDI-FX tab. Finally, restart your zynthian and they will be available as MIDI-FX.

I will test it tomorrow … :wink:



Wow! @jofemodo, you’ve sold me on this project. I bought a Zynthian 4.1 kit today. And thanks for your super speedy kind response!

1 Like

Here comes the :face_with_monocle:

It’s done with a simple MIDI-LFO modulating the ZynAddSubFX cutoff. Here the snapshot:

005-ZY _ net-wisdom_Vangelis Saw - C.zss (17.8 KB)

I’m working for improving the integration of these new toys :wink:



OK! It’s really funny … here comes another :face_with_monocle:

this is made by using 2 MIDI-LFO modulators, on cutoff and resonance. Here the snapshot:

005-Bimodulated Vangelis Saw.zss (19.9 KB)



Yes! It’s alive!
Very rich constantly changing sound.
Sounds great!

Zynthian becoming modular…

Sorry, does not work for me. I never get the new plugins in the list of available ones. Perhaps because the installation script is inside the “pending” folder?

hmmm, there is a script in the normal recipe folder… will try this first by calling it manually.

Regards, Holger

No, it seems that everything is installed at /usr/local/lib/lv2/. But a mv /usr/local/lib/lv2/qmidiarp*" /zynthian/zynthian-plugins/lv2 helps…

@C0d3man, did you follow all the steps ?

Yes. But there was an update problem (see issue #274). After fixing it and updating/rebooting again there were no qmidiarp plugins, so I had to install them by hand.

[EDIT] For the Z_v4 (with slightly better updated software) this problem does not happen - everything works fine. That’s sometimes a little bit strange - a little bit like Windows 95/98… It seems to be a problem when not updating regularly. With too many steps in between strange errors occur. Unfortunately I have no solution for this problem.

Regards, Holger

If you are no updating from RC-2 SD image, you will have problems for sure. I ONLY test updates on last image…

That’s the strange thing: I have RC2 on all my Z’s. Next time I have to take a snapshot before updating.

I think there is sometimes a problem with dependencies of previous updates, which are not done when not updating regularly.

BTW: My Z_v4 has had no problem when with updating - it’s the machine with the most frequently updates in my arsenal.

Regards, Holger

1 Like

I will try to improve this by testing updates on fresh-burned SD images.


1 Like

I am still interested in one thing he said, would it make sense to be able to make presets and sound design in the unit itself?

I’ve been thinking about this and maybe we can make ui module that shows an overview of all parameters (or at least the ones assigned to midi) so we can sound design more on the unit itself.
I know this is a huge thing to implement but maybe for some of the more basic synths (TAL NoiseMaker, for example) it would make sense?

So, I did now the following:

  1. Download latest Image (2020-09-05-zynthianos-buster-lite-armhf-1.0.0.img, refererenced from web page).
  2. Installation
  3. Reboot
  4. Update
  5. Reboot
  6. Restoring data backup
  7. Reboot
  8. Installing and activating PT-6.7.3
  9. Reboot (hi WIndows :woozy_face:)
  10. Setting UI and Hardware options (PiScreen-2.8" res, Prototype-3H, HifiB-DAC+)
  11. Reboot

The first strange thing: When pressing the Learn/Shot button (the upper right) ZynSeq is shown. But I wanted to load a snapshot!? :open_mouth:

After explicitly removing all layers I tried to load one of the upper snapshots via menu - won’t load. UI-Log:

Oct 31 18:41:19 zynthian startx[506]: libjackpeak created input ports
Oct 31 18:42:00 zynthian startx[506]: WARNING:zynthian_autoconnect.cb_jack_xrun: Jack Audio XRUN!
Oct 31 18:42:00 zynthian startx[506]: WARNING:zynthian_autoconnect.cb_jack_xrun: Jack Audio XRUN!
Oct 31 18:42:18 zynthian startx[506]: ERROR:zynthian_gui_layer.load_snapshot: Invalid snapshot: 'JV/QMidiArp LFO'
Oct 31 18:42:18 zynthian startx[506]: Traceback (most recent call last):
Oct 31 18:42:18 zynthian startx[506]: File "/home/pi/zynthian-ui/zyngui/", line 1181, in load_snapshot
Oct 31 18:42:18 zynthian startx[506]: engine=self.zyngui.screens['engine'].start_engine(lss['engine_nick'])
Oct 31 18:42:18 zynthian startx[506]: File "/home/pi/zynthian-ui/zyngui/", line 168, in start_engine
Oct 31 18:42:18 zynthian startx[506]: info=self.engine_info[eng]
Oct 31 18:42:18 zynthian startx[506]: KeyError: 'JV/QMidiArp LFO' 

That’s exactly the same error I good two days ago when qmidiarp was not installed. qmidiarp is not listed in the available plugins and (I guess) when installing by hand it will work…

Is this reproducable by others?

Regards, Holger

What is the content of your data backup?