Motu M2 External Interface / Sound Card Splash / Error IP Screen Loop

Screen came in and I tried to get everything running…

Attached screen, booted up, connected to network and selected the Raspberry Pi display… everything worked at that point…

When I plugged in my Motu M2 interface and selected Generic USB Audio as my audio device and rebooted, it started looping the splashscreen and the error screen

Googling and experimenting, but figured I’d post in case anybody had been down this road before or knew approximately what I needed to do

You need to find out what name your Moto M2 presents as to alsa. Open a command window (ssh / webconf: INTERFACE->Terminal) and type aplay -l. The results will look something like:

**** List of PLAYBACK Hardware Devices ****
card 0: vc4hdmi0 [vc4-hdmi-0], device 0: MAI PCM i2s-hifi-0 [MAI PCM i2s-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: vc4hdmi1 [vc4-hdmi-1], device 0: MAI PCM i2s-hifi-0 [MAI PCM i2s-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: sndrpihifiberry [snd_rpi_hifiberry_dacplusadcpro], device 0: HiFiBerry DAC+ADC Pro HiFi multicodec-0 [HiFiBerry DAC+ADC Pro HiFi multicodec-0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

You need to identify your M2 soundcard in thie list then in webconf: HARDWARE->Audio, replace hw:0 with hw:name_of_your_sound_card in the Jackd Options field, save and reboot. Using the example output above, if I want to use the first audio interface I would use hw:vc4hdmi0.

Okay, found that… set hw:M2 and I’m out of the loop. Was afraid it would be much more complicated than that.

Looks like I can get levels on my interface too, so that’s good. Haven’t gotten the speakers set up just yet, and haven’t tested audio input.

Got the display flipped over also - anything I need to look out for with that other than deleting the “lcd_rotate=2” line?

Think from here I need to just follow some tutorials to get past the UI navigation learning curve and we’ll be off to the races.

Thanks for the assist :face_with_monocle:

In theory you should be able to use the Screen Calibration in the admin menu (may need to plug in a USB computer keyboard to navigate) but some have reported this hasn’t worked. It is certainly designed to fix this problem.

@riban I’m up and running with Pianoteq 8 stage. Played around with OBXD and Dexed, it all works a treat. If I don’t get it all 100% dialed in I’m still totally happy with how this thing is running as is, worth what I put into it for sure. Much appreciation for the big brains that made Zynthian possible.

1 Like