Mouse cursor not showing with latest-stable UI (HDMI)

Hi, I’ve just discovered Zynthian and wanted to try to get a sense of the capabilities before committing to build an actual hardware device. I had a spare Pi sitting around, so I formatted the SD card and booted it to have a look at the user interface.

Raspberry Pi 3B
HDMI out to standard HDMI 2760x1440 monitor
USB keyboard
USB Logitech mouse
Standard Pi power supply
latest-stable ZOS

The OS boots normally, reconfigures itself, reboots and lands at the home GUI. The keyboard seems to be working fine in that I can navigate through the standard menus, but the mouse seems to be unresponsive. Clicking the left button will usually act the same as the ENTER key but there is no cursor so I can’t use the mouse to select many items, or even get back to the root menu. I can’t find any keyboard command to go back to the top menu despite searching in the webconf settings.

I logged in remotely via ethernet to the webconf ui and made sure that all the pertinent settings were ticked (show cursor, etc.) then rebooted the Pi. No change. I’m aware that my Pi is not the recommended device, but I haven’t even tried generating sound or going beyond the UI basics due to the mouse/select problem.

Am i overlooking something obvious? There’s an old thread that indicates someone has filed a bug report for a similar issue, but I can’t find any recent references to it.

1 Like

OK, the Zynthian lesson of the day is: just because you’re using the “latest” distribution, never assume that there aren’t updates! After trying a bunch of things, multiple reboots, lots of dead end side trails, etc. I thought as a last ditch effort I’d try the webconf “software update”. It downloaded a ton of stuff, updated Z and when it rebooted (again) the cursor has happily appeared and the UI works . Now to start making sounds…


Hi @GregDunn!

Welcome to this lovely community. I am glad you are tipping a tentative toe into the warm waters of Zynthian, taking a very pragmatic approach, using existing kit to test. Very good idea!

There is a symbol that appears in the top right corner of the screen that provides indication of various states. By default it shows a green heart, indicating all is well with the world. This can change colour (orange, red) to indicate increasing load which is undesired. It can also change shape: a thermometer indicates high temperature and an exclamation (!) indicates xruns (failure to pass sufficient audio data resulting in clicks). It can also change to a cirular circle ( ↻). This indicates there are updates available.

The images are built when a new major version is released then updates are made available to patch the image to the latest minor version which may include bug fixes and feature enhancements. Building, uploading, downloading, extracting and installing the image takes significant time, hence it is not updated with minor version patches. (You could compare this with pretty much any OS that may have traditionally been supplied on floppy disc, CD, DVD, etc. which would not have changed and is now generally provided via a download of a similar image that similarly does not change.)

I am glad you have solved the problem - the next challenge is making some sound (and of course, sharing it :face_with_monocle: ).


I have recently built a couple of other Pi-based synthesizers for when I didn’t need (or want) to hijack my main computer to play with some sounds. But everyone seems to feel that “If you’re serious” about doing computer-based synthesizers, Zynthian is the way to go forward. I usually have a spare Pi sitting around from one project or another, so…

I had read about the notification symbol in the wiki before installing Zynthian. However, all I got was the xrun notification (probably because I am using the internal audio temporarily, had needlessly enabled VNC and this is not the fastest machine!). But other than that, the heart stayed green the whole time and no update was indicated. Even the webconf didn’t say there was an update but I knew it was worth checking.

And so far, sounds have been coming out easily. Once I internalize the chains and other characteristics of the model, it should be OK.

You’ve not read the threads about rooks and soup then…?

They tend to pursue late offerings, but in truth, they are not very good at it…

Welcome aboard.