Mouse pointer on Pi 7 inch Display

Hi there,

finaly got a minimal Version of the Zynthian working - more or less:
I’m using Raspberry Pi 3 Model B v1.2 together with the official 7 inch Touch Display, no encoders and for testing the internal Sound via headphones out only.

Well, got it Running without any errors, whatsoever… BUT: there is the mouse pointer stuck in the middle of the screen. Touch is working, can select menus etc, but the pointer is still there.
Quite distracting.
Also an full update didnt change anything.

Another problem, everytime I want to access the webconfig or for updating, I have to use a old router, the actuell one cannot find the zynthian, or it apears on the Router, but cannot get an IP…

Somewhere there was a comment, the mouse pointer has something to do with the “wiring scheme”, or vice versa. Do I need another scheme than “Dummies”??
Or any ideas, how I can supress the mouse pointer by force via a custom startup command??

Many thanx in advance, the Zynthian is really great and I’m looking forward integrating this nifty device in my Eurorack.
Ah, btw I remember a picture featuring a Zynthian Eurorack Edition with CV and Gate In/Outs.
When will it be realeased? Still OpenSource?? :wink:

On WebConf you can arrange everything however you want… but people who are more knowledgeable than me will certainly answer you… :wink:

Unfortunatly these settings doesnt change anything for me - allready checked them :wink:

If you are sure you have selected the right display on WebConf… my knowledge stops here… you will see that in a short time some expert in the forum will enlighten you… I’m sorry I wasn’t helpful…

Selected the Pi 7 inch touchscreen, yes.
There is something with ‘ndtoverlay’ in the options, dont know the meaning and I couldnt find out what that suppose to mean - but I suspect it belongs there.

I hope there is something like a optional start command to supress any pointers.

If you changed them, you might have to restart Zynthian afterward, for them to take effect.

I did many reboots :sweat_smile:

Have you tried using the screen configuration tool in the admin GUI?

You mean the ‘Calibrate Touchscreen’??
Yes, the frozen mouse pointer is still there.

Hi @Synthfan! A warm welcome to Zynthianland.

Please confirm:

  • You have disabled “Enable cursor” in webconf
  • The pointer does not move when you attach and move a USB mouse

Please post screenshot of webconf main page and User Interface page.

Yes, I can confirm that ‘enable cursor’ is unchecked.
But the pointer does move with a mouse. Without the mouse it just frozen, doesnt move along the finger BUT I can select menus anyhow.

Here are the requested Screenshots.


I also use a 4.3’ waveshare DSI display.
My Zynthian box has exactly the same problem.

Sorry guys! I have experienced this but when I started to investigate I did not see the issue. I suspect I may have resolved the issue on that machine so will have to figure out what I did. I suspect it is a modification to the zynthian service script relating to X.

[Edit] I just checked and that modification is not in place but I still don’t see the issue so it may prove challenging to diagnose. I think it relates to X showing its naitive pointer rather than any overlay that a DE might normally provide. You could try adding -nocursor to the end of the ExecStart line in the file /etc/systemd/system/zynthian.service but this change will be overwritten during subsequent updates. Let us know if this helps and if so we may be able to add it to the default config. (Needs testing on all platforms.)



“-nocursor” in “zynthian.service” solved the problem on my zynthian box.


Oh, that sounds promising if it works out for you. Hmm, sorry for that stupid question: how can I modify that script on the box??

I’m kinda new to Linux in deep, despite my Laptop runs on it. But the Terminal still scares me.

I know where to find the Terminal via this webinterface - but then what??

Unfortunately the teminal implementation in webconf is flawed. It does not display the whole screen and wraps too early and with unexpected results. This makes it very confusing to use. I would recommend you drop to the command line on your Linux laptop and do this:

  • ssh root@zynthian.local This should connect you to the zynthian after you enter the password “raspberry”, assuming default configuration. If your zynthian appears with a different hostname or address then use that instead of “zynthian.local”. You can use its IP address instead which can be viewed from the admin menu or webconf main page, e.g. ssh root@
  • nano /etc/systemd/system/zynthian.service This will open the simple text editor called nano. You can move the cursor around with arrow keys, insert text by typing and delete text with delete / backspace.
  • Add the options to the desired line.
  • Ctrl+x Holding ‘Ctrl’ then pressing the ‘x’ key will offer to close the editor and save the changes.
  • y Pressing the ‘y’ key will close and save. You can press ‘n’ to close and not save.

I hope this works for you. Let us know if this fixes the problem and we can look to add it to the base build.

1 Like

Yeees, the pointer is finally gone!
Thanx a lot, for the quick reply and the detailed explanation. Looking forward fiddling around with the box in the evening.


Thanks to both of you for testing this solution. I will look at how it may be configured in the core code. Please be aware that the change you made to the service file is likely to be undone by the normal Zynthian maintenance routines so your dreaded ghost pointer may be back to haunt you soon… :ghost:

Congratulations on getting rid of the poniter. NOw we have a completely unenforcable thank you that you may wish to indulge us with…

It’s explained here

Don’t worry it’s just about getting some content from people that have been helped.


I have pushed this fix to the testing branch. If there are not subsequent issues discovered it should be in the next stable release. I also added a fix for screen blanking. Zynthian now has its own power saving mode that controls screen blanking so the X screen blanking is undesirable. (It bugs me a lot during development and debugging but isn’t a big issue in the wild.)