My red lightning bolt warning

…is literally always on. I have a 5v 3amp adapter, which is what (I believe) is recommended? I bought it new at Staples, so I am pretty confident that the adapter is what it says it is. Even when I am doing a simple 1 layer, single synth thing, the warning is constantly on. I have tried other adapters, but these were at lower amperage (2amps, 2.4) andthe warning was there as well. In fact, since I got this thing, I’ve never been able to really test it out, always the warning is on, and there are dropouts and sputters, etc… I have the kit version 3, I got it in July… Any help would be appreciated. It really isn’t any use at the moment

A common cause of this is poor power cable. You say you have a good PSU but what is the cable like? Telltale sign is a thin cable. If you have a multimeter you could measure the voltage on the RPi header (negative to pin 6, 9, 14, 20, 25, 30, 34 or 39), positive to pin 2 or 4). The measured voltage should be close to 5V. If it is less than 4.9 you may suffer. Try to measure this with all peripherals connected.

1 Like

So, full disclosure - I bought my Zynthian kit not knowing that I was getting something still in development. I am not an electronics guy - don’t even have a multimeter, don’t know what a rpi header is. I am a little annoyed with myself for not researching this further, and at Zynthian as a company for having a kit without a power supply included, especially given that it uses the very shoddy quality USB mini connector. Does anyone have a link to an amazon product they have bought and successfully used? I already have spent 40 bucks and don’t want to have to keep buying different PSUs… As it stands right now, I simply want to make sure that I have a unit that works correctly that I can sell

Like @riban said, the cable is often the culprit. For powering a Raspberry Pi, the official RPi power supply seems like a safe choice, and comes with a cable so that part is taken out of the equation as well. That’s what I have (but did not purchase via Amazon / that link precisely)

Besides the cable, another thing to watch out are USB hubs (including powered ones!): if you have any connected to the Zynthian, try with a minimal setup without one. AIUI some powered hubs can cause RPi to feed off the hub, which is guaranteed insufficient, and unpowered hubs can suck off too much power from the RPi otherwise.

Note that Zynthian is not a company but a community project built around Raspberry Pi. That said, power problems are common (been there, studied the subject more than I would’ve cared), it’d be really helpful if the Zynthian shop carried a known-good PSU that newcomers can pick along the kit.

We’ll look after you, don’t worry.

Also, can you upload a photo? the power lightening bolt is yellow, not red.

well, I bought a usb to usb micro cable at my local computer store, and it seems to have solved the power issues (though the lightning warning most certainly was red??)

SO now I am connected to my local network, I have perused the webconfig page, and now I have launched a special layer on my Zynthian, and loaded up the MOD UI interface on my computer. I’ve put together a small setup with distortion and reverb to test the whole thing out. I saved the setup to my Zynthian, loaded it from the unit itself, I can see all the parameters, and the signal path seems right - but it doesn’t pass any sound…

to troubleshoot, I added a synth layer, and it makes sound. I the tried adding a simple distortion only effects layer, and it passes sound. But the MOD UI special layer doesn’t pass sound. I loaded one of the “factory” presets that came with the Zynthian and also, no sound.

so the question is, am I missing something with the hardware? or the software? I’m probably no longer in the right category…

or maybe I am? I am not even really sure what the routing of the actual hardware is - in the V3, are the 1/4" jack and the 1/8" jack 2 seperate stereo inputs? Or are they parallel inputs? and for that matter, I assumed they were stereo ins, but maybe they are balanced mono ins? And either way, how are they routed in the MOD UI? I have them routed from the “hardware capture” ins through the effects chain, to the “hardware playback” jacks (in the UI). But then, “hardware monitor out 1&2” also can be patched to the ins of the effects chain. So yes. I am a bit confused by this. I have looked around the wiki, but I am still in the dark, and there are no web tutorials that I was able to find.

Anyway, thanks everyone!

Good to hear you got it sorted! says the undervoltage warning lightning is indeed red, and that matches my recollection from a few months back. Maybe it’s been yellow at some point in the past?

Assuming you have Hifiberry Pro soundcard (IIRC the default in v3 kit), the 1/4" audio input jack is balanced mono, the 1/8" jack is unbalanced stereo, separate and entirely undocumented AFAICT and unclear even in the Hifiberry spec sheet. The input is selectable in the ALSA Mixer “app”. Caused me a fair amount of confusion too. The balanced input is at least mentioned at

No clue about MOD-UI though, I haven’t used that at all.

Excellent.! hopefully you understand the implications of :face_with_monocle:

Hey - you mention the ALSA mixer - mine only has 2 controls, digital left and digital right - not the ones shown in the user guide. But I can confirm that it does pass audio through both the balanced 1/4" in and both sides of the stereo 1/8" in. A reason I want to get the MOD UI sorted is that I would like to split the inputs and rout 2 different audio sources through 2 different layers and it seems like it should be straight forward with the graphic interface, but going through creating an effects layer on the zynthian itself, I can’t seem to figure out how to rout audio from a specific input or to a specific output, even a simple left or right pan (I mean, within some of the effects themselves there is a pan, but it seems there should be an audio routing bus…)

And again, thanks for your patients with me, like I said I am not a computer or electronics guy. IAM an audio guy, and I know something about synths, haha… but troubleshooting a device I am altogether unfamiliar with (raspberry pi, linux…) is beyond me ( and yes, I jumped at the price and the specs and the couple videos I saw - a little more research would have shown me that it is a platform that is still in development, which, again, is not my interest - BUT, the synths sound nice, and I can almost see how to get everything working :slight_smile:)

MOD-UI is very pretty and quite cool but it does have some limitations. You can do what you describe using standard Zynthian layers, e.g.

  • Add an Audio-FX layer, e.g JV/MDA Dynamics
  • Highlight the layer in the layer screen and Bold press the Select switch to show the layer’s context menu
  • Select “Audio Capture” which will show a list of the audio inputs available
  • Select / deselect as required, e.g. select only the left input
  • Within same layer context menu, select “Audio Output” which shows a list of audio destinations available including soundcard outputs, inputs to plugins, etc.
  • Select / deselect as required, e.g. select only the left output
  • Within same layer context menu, select “Add Audio-FX” to add more plugins to the effect chain
  • Repeat for other channel, i.e. add effect layer, route inputs and outputs, add other effects


1 Like

What image are you running?
It sounds like a glitch from an earlier release candidate.

Either way, it’s easily fixable by running a Software update
Or from the webconfig: go to audio configuration, ALSA mixer and check the boxes to include these properties: “ADC Left,ADC Right,ADC Left Input,ADC Right Input,Digital Left,Digital Right”

BTW: powering your zynthian with any good power delivery powerbank solves lightning bolt problem forever and makes your zynth portable. It can deliver 5V 5A for devices demanding it.

I am using this one from aliexpress - works great !

p.s. it also helps in some gig cases, were there is no proper grounding installed and you get some noises in the line, hum (50Hz or 60Hz depending on the region). In my cases this kind of powerbank solution works 100%.

1 Like

I think I discovered where those options went - my webconfig was set to V3, where there are only limited audio options in the mixer. In V3 pro those options are available

@twelve, perhaps @steveheyerdah don’t have a HifiBerry DAC+ ADC PRO :wink:

Anyway, it’s a good moment to encourage everyone to update their SD image to the last official image:


Can you charge that power bank whilst it is providing power to the Zynthian, i.e. use Zynthian with power bank plugged in to a charger?

Yes, you can indeed :grinning:

p.s. but the wire (USB > USB-C or USB-C >USB-C) should be able to transfer 3A or 5A, specially charging zynthian.

p.s. there is a small lightweight 10000mAh version too on aliexpress - works well too. Power delivery and fast charge technologies are the part of the package.