My router doesn't assign an IP

Hello everyone :slightly_smiling_face:
I’m at a loss, I have the Raspberry pi 3B+ the current SD card image
Then connected directly to the TV with HDMI and plugged the network cable into the router and it boots correctly.
I can see the user menu on the screen.
It doesn’t display an IP under network info.
I can’t see the Raspi with Zynthian in my router either.

As a cross-check, I started RaspberryPI-OS and yes, I am assigned an IP.

Without an IP I cannot access the webconfig to tell Zynthian my configuration.

That’s why I wanted to install an older Zynthian Gorgona image because there were no problems with this image.
I downloaded the older SD card image, but it cannot be unpacked.

I’m at a dead end because all the information on Wikipedia doesn’t work either.

I am a Windows 11 user and have very limited Linux knowledge.

This text was translated using Google Translate.
I am grateful for any help.
Feedback geben

Do you have the RPi ethernet plugged to a router port? Have you tried entering the address http://zynthian.local? Have you tried connecting directly to a computer and using that address? Have you tried enabling WiFi from the admin menu and connecting that way?

I tried unzipping the file to see if I could put the actual image file up for you and eliminate the possibility that the problem was your unpack and got the error message “An error occurred while loading the archive” so I think we will have to troubleshoot the problem using either stable or Oram.

Have you tried both of them? If not the other would be worth a try.

Another possibility I can think of would be hooking up the Windows machine directly to your Zynthian instead of through the router. This might require a “crossover” cable depending on your Windows machine and the Pi3 hardware.

It also might be possible to get some better info on what is going wrong from the Zynthian or logs on the SDcard - but I think that will require help from someone who knows more than me…

and now I see that Riban has already replied with some overlap to my post so I will go ahead and send this but don’t let me interrupt…

Thanks for your answer. I have a crossover adapter somewhere that I’ll try out when I find it. I only tried one of the Gorgona images. Where can I find the log files on the Zynthian SD card?

Just run journalctl

I’ve tried everything except connecting directly to the PC

Does the same cable work with the pc?

I have no idea where I should run what, did you mean via the Linux console?

Hi @D64FAN63 !

Please, forget Gorgona image. It’s very old and totally unsupported. I just deleted the broken gorgona image from the server so nobody will download it nevermore. The latest stable or the new testing (Oram bookworm) image should work OK. @riban and myself tested in “RBPi 3B+” and it works.

If you see the UI, then the OS is running and network service is up, for sure. If you connect with ethernet cable to your router, it should receive an IP and allow to connect. If zynthian don’t get the IP and the router don’t see it, it looks more like a “hardware issue”. The router should see the network interface from the RPI!! I would check for:

  • bad cable
  • bad ethernet port in the Pi
  • bad port in the router

Also, have you tried to configure the wifi from the admin menu? Can you see some WIFI networks in the list? Have you tried to enable the WIFI hotspot?

And finally, did you test with a “standard” RPiOS image to check if it’s a hardware issue?


@jofemodo from earlier post:

Sorry! I read too fast and jump over this.

It’s really strange that ethernet don’t work. It always work!!
I will check with Pi3 again to see if some recent firmware update has broken kernel support.

Could somebody else with a Pi3 confirm this issue in Oram Bookworm image?


As I said on RaspiOS everything can be seen and connected in the router.
There is no WiFi list in the admin menu on my TV. I can only tick the WiFi and then it searches for a while and then cancels (no network connection) and goes back to the menu. Well, now I’ve put everything back in the closet and am waiting for chance that the solution will be found. Greetings from Hamburg Peter

I’m happy to tell you that after installing “zynthianos-bookworm-aarch64-oram” I at least got access to my WiFi. I’m currently running an update and I’m excited to see what happens next with the function. Greetings Peter :joy: