New 7" screen struggle

Dear zynthianers - hello to everyone !

I have found myself a new quest and almost succeed. Almost is the keyword here.

It is GEN4-4DPI-70CT-CLB touchscreen with GPIO interface, resistive touch 7" with 800x480 resolution. Very nice screen I must say !

After a few days of struggling (changing kernel for the specific version of their drivers and et cetera) I have managed to make the screen itself work nicely on RPi 4 with audioinjector stereo and zynaptik module.

Everything works except touchscreen :frowning:

It is based on AR1020 chip and has ADS7846 driver responsible for interfacing. But it doesn’t want to work yet. I suspect the problem is in badly written drivers and also in SPI interface but the strange thing leaving the screen alone on RPI doesn’t change the situation:

 dmesg | grep spi
[    0.188720] spi-bcm2835 fe204000.spi: could not get clk: -517
[    0.278322] 4d-hats spi0.0: 4d-hat registered, product code = b4

All the same…

Have anyone struggled with similar SPI issues ?

Any advice ?

The ads7846 is at the root of the 3. 5" screen that had all the touchscreen issues so there might be insight there. It wasn’t so much getting the touchscreen to work thou’.
I work on the premise that I’m not the first person to try anything and start by trying to get Raspbian to work so you are at least able to employ a much wider user base and if you can get that working you do at least know it can be done. I’ve used the standard 7" screen and I just add one wire and it runs as hdmi without a problem. Obviously once again not much help. A couple of pictures might help from the recognising components from which we might be able to puzzle this out.


did you try your display on a regular raspbian distro ?

Thank you for replying and sorry for delay with the answer.

I have got the message from 4d systems (the makers of this screen) - my screen is the capacitive touch one, not the resistive. Unfortunately the makers of this screen don’t help much with any drivers or whatsoever. The manuals are not so clear about drivers installation too - had to discover most of everything myself. Will keep looking.

Here is the fully working prototype:

And the screen in details:

@wyleu, it is not a standard screen, just got it by occasion and for a very reasonable price. No touch - fine for me, will use the mouse if necessary (for sequencer etc.). Got used to usual zynthian controls anyway.

@le51 - have tried a few distributions of Raspbian and touch doesn’t work out of the box. The first time I have tried this screen with raspberry Pi2 and moode audio player image, touch control worked for once. But with RPi4 now it doesn’t - still investigating the possibilities.