New build black screen

Yes this screen is a pain, but I’ve managed to get it working many times ago.
Let me have a look

1 Like

Thanks again everyone for the support, really appreciated. This journey has definitely been a good meditation practice =)

Initially I lost about 6hrs due to Balana Etcher bricking both my new SD cards which is something I’ve never seen before.

After managing to essentially unbrick one of the SD cards and use Rasberry’s native imaging tool, they still take much longer than I remember to deploy the image.

I accept this will be an exercise requiring patience, but have no doubt it will be more than worth it at the end.

I’ll also gladly document the journey to hopefully help others going forward.


1 Like

A brief update:

After wiping the SD card again, I retried the MHS35 custom setting, looking at the UI logs, it seems the UI is running, however the screen remains white. Kind of feels like progress?


Another brief update:

I will work through the screen driver install/config file line by line and make all relevant changes made by the script on my install until I hopefully see the Zynthian UI instead of the white screen.

I will document the changes in a copy of the LCD35-show file, detailing which changes were made or if changes were not applicable.

I’m hoping once this is complete, it will shed light on the specific changes required and then also feed into the next step of making a pull request to add the custom display.

Please let me know if this is a sound/logical approach and if there are any specific things I should avoid doing or stick to, particularly in regard to Zynthian custom config.

It’s also worth noting, I have initially scanned across multiple google results regarding specific errors and will likely reference any previous posts as part of this investigation process.

Thanks in advance.

1 Like

Yeah that’s good. I’m just doing exactly the same as you starting from a fresh new SD Zynthian install.
10 mn left until SD card is burned …


Starting from a fresh latest stable install:

  • via ssh access:

git clone
cd LCD-show/
cp ./usr/tft35a-overlay.dtb /boot/overlays/
cp ./usr/tft35a-overlay.dtb /boot/overlays/tft35a.dtbo

  • via webconf:
    Hardware → kit → custom → save
    Display → custom-> set :

width: 480
height: 320
framebuffer: /dev/fb1

=> reboot: It works except Y axis of touch interface wich is swapped.

BTW, that’s how mine looks like:

1 Like

Thanks, will replicate exact steps and update, I was literally dissecting, documenting and rev engineering / learning at the /boot/config.txt stage. Will update shortly, although my clean install is now a bit tainted so may re-image also.

Thanks again.

@le51 you are an absolute star!

I think I needed a better understanding of the question before trying to find the answer. You’ve without doubt saved me many hours on a sunny Friday.

Thanks @le51 , @jofemodo and everyone else who posted!


Once everything is fully working and tested, I’ll do the write up with full details.



1 Like

Hi, hopefully a quick and simple question, but what is the correct way to manage screen axes calibration? I tried multi configurations in /etc/X11/xorg.conf.d/99-calibration.conf

So far I tried using the keyboard to navigate to the menu on the UI, along with the xinput_calibrator writing out to 99-calibration.conf and various combinations passed to the dtoverlay in UI config (e.g. invx=), but nothing seems to be making any difference.

The screen is the right way up, but stylus up is left, down is right etc.


IT runs in a similar fashion (touchscreen reversed) on a Pi 3 but a mouse exhibits the select the first element in the list effect alluded to elsewhere… Using it from a arduino encoder box occasionally goes down the select list but jumps back to the top selected item, same happens with a keyboard.

So it looks like I can resurrect zynthian-touch.local.

It runs testing too…

Hey @wyleu, thanks for the reply.

Sorry if I’m misunderstanding, are you saying the axes can’t be rotated and a mouse is needed in this instance?


The behaiour seems very similar to what is reported here …

Ahhhh…interesting, I didn’t see that post from @le51

From the testing I’ve done so far, I’m able to run the input_calibrator without issue and it seems to spit out the relevant mappings, it just seems the O/S isn’t using/detecting the config.

I’m keen not to use keyboard and mouse if possible, the new setup I’ve just constructed was largely intended to not feel computer driven (see pic). That said, I’ve currently got the Zynthian box doubling up as a Midi interface which is handy =)

Worst case I will just get a supported and tested screen I think, but will try to do more on the config of this one and will post any progress.

Yes, this has all the feel of the original dance we had to do to get this to function. I learnt one hell of a lot about screen details which I promptly forgot.

In theory you should be able to access the admin/screen calibration using a USB keyboard or mouse and then calibrate using touch. After this, touch should work as expected. I think someone once reported this didn’t work for them but I’m not sure I saw a GitHub issue report.

1/ git clone GitHub - goodtft/LCD-show: 2.4" 2.8"3.2" 3.5" 5.0" 7.0" TFT LCD driver for the Raspberry PI 3B+/A/A+/B/B+/PI2/ PI3/ZERO/ZERO W
2/ cd LCD-show/
3/ cp ./usr/tft35a-overlay.dtb /boot/overlays/
4/ cp ./usr/tft35a-overlay.dtb /boot/overlays/tft35a.dtbo

5/ * via webconf:
Hardware → kit → custom → save
Display → custom-> set :

width:—> 480
height:—> 320
framebuffer:—> /dev/fb1

6/ Restart
7/ Screen displays correctly.
8/ Touch screen XY reversed i.e. vertical movelments produce horizontal movement of cursor
9/ Attempting to select items on screen in admin virtually impossible with reversed axis, and mouse operation continually drops back to selecting top menu item, similar behaviour with keyboard ( re-position not triggered by anything specific it just moves back)
10/ Any attempt to select a different menu item selects the top item in select list…
11/ Hurl device at wall using technique described by @riban and chuckle lightly at being the person who gave him the screen.

LOL @wyleu - replace step 11 with ‘Slow deep inhale through the nose and breath slowly out the mouth’ * 5.

As promised I’m drafting my installation notes and will make them pretty and ready to share once everything is working. The notes will include:

  • Direct links to hardware used and link to driver/overlay repo.

  • Note on issues encountered with Etcher and a work around for Mac or Linux users to write the SD image using diskutil and dd. (will include warning)

  • Process used to access the device initially without using a keyboard and monitor (using ethernet and then nmap or your router to determine IP address and then Wifi setup via the Webconf)

  • Process to copy overlay files to /boot/overlays

  • Initial Webconf hardware setup including Custom Kit, Audio, Display and Wiring etc.)

  • Method used to setup a Midi Interface (Midisport 2x2)

  • Method used to have the system recognise KeystationMini 32 direct over USB

  • Method used to check Midi signal is working.

  • A method to work around the screen axes inversion issue (use of a small wireless Logitech K400 with touch pad)

  • Links to Project documentation and getting started video.

However, … although we now have the web ui working, midi working , screen working, …the sound is not working, the best I can get after creating a layer is a barely audible sound with what sounds like interference over it.

I can see the midi register and the green bars indicating volume, but the sound is not working. I’m assuming there may be some further configuration required for the Raspberry Pi 4B (Model B) Rev 1.2?

I will trawl the forum for sound issues, but if there are any basic setup steps I’ve missed for the 4B, please let me know.

Edit:Details of sound card below - I will work through standard raspberry pi sound troubleshooting issues and confirm if sound is working outside of Zynthian.

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3

card 2: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 3/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3

EDIT UPDATE: I can confirm in webconf I’m using the default ‘Rbpi Headphone’ option.


I don’t think rotate has an effect on this driver. My screen is upside down and the parameter does not change it. I can’t test further because I only have a spare RPi2 which won’t run the Zynthian version of jackd.