New PD patch: ZynthASketch

Here’s my latest patch called ZynthASketch. It lets select brush color and brush size. I could only get this patch to work with a Buster image. It works on the RPI3 and RPI4 Zynthian. There is no audio, it is only a video toy. I also tried to run this via ssh X-Window with no luck. The patch is mapped to midi cc controls and I used my Minilab controller as my Zynthian doesn’t have encoders. (1.3 KB)


What an enormous waste of time. I love it. More.


Can we get this onto the HDMI monitor port at the same time? My XWindows knowledge precludes any useful efforts in this regard but I’d love to have an explanation of X and Pi’s and stuff…

I guess when the draw window is launched you’d add DISPLAY=:1 /bin/drawwindow or something to the display line.

Always seems rather hit & miss. I assume a framebuffer needs allocating somewhere in memory for the X window instance. So how does this interact with systemd? and can the destination of the stream be steered?

We are in the same boat. I don’t know how but will try to figure something out. I still don’t have any micro HDMI cables for the RPI4, but I’m hoping they will work out of the box with zynthian (fat chance). I’m also hoping the GEM window can be slid to the right hand screen with the ‘Win X Position’ controller. Have you tried anything with the RPI4 dual HDMIs yet? Anyway, it would be better yet to find a way to steer the video stream to an HDMI port.

Woaw !! If this is not a compliment, then what is it ?? :wink:

1 Like

Snake game, anyone? :grin:

1 Like

Yep, it is nothing but a compliment.

I think it’s a little wierd that we were just talking about sketching…

Thare are invisible links under the ground, that connects people’s minds I’m sure…

1 Like

I understand that export DISPLAY=:0.0 can access the lcd screen if it’s there, but is there a similar directove for starting an X-Window on my remote machine…? anything I try to set Display to seems to come back with invalid screen.

xwininfo -tree -root generates much information when DISPLAY is set to :0.0 but has bustern played around with this area cos i’m no longer able to get a display on my remote machines as before?

D’Oh… I hadn’t got X forwarding turned on for Putty for the machine . . . .

so when I connect via an ssh Putty terminal with X-Forwarding turned on …

I get a default setting of DISPLAY=localhost:11.0


1 Like

Well I fell out of the boat and when I surfaced, you and the boat were gone. Are you wanting to display the Pd GEM window on a remote machine or on a separate monitor attached to the zynthian or both? My best guess is you want to use the zynthian with two displays and you used putty to tell you the $DISPLAY name to help you continue your quest, correct?. I’m confused (but it doesn’t take much). @wyleu please throw me a life preserver.

Pretty much I got summoned for food mid post so that’s as far as I got.

1 Like

Yes, I’d like the scope to be on the hdmi connector and the GUI on the zynth screen.
I have never had anyone say if that is or isn’t possible. But having now found a way to det the display setting for the ssh window helps. Quite if you can set up to X windows with the Broadcom video set up is something I don’t know. Presumably two frame buffers are required but, again, I’m not sure if that can be set up. Presumably on a Pi4 which has two hdmi ports the possibility of at least two Windows should be possible.

It’s just one of those areas that one would just ask the local guru at work, but as with most of these things it’s a matter of how to phrase the question. seems to do something rather similar.

I found the same video a few days ago while researching this issue. I’m hoping a dual screen on a RPI4 will be easy to accomplish. If not, I may refer back to the video and see if I have any luck. I’m waiting for micro HDMI adapters before I get in too deep. If it works like a typical dual screen, I’ll edit the pd patch to allow moving the image further off of the 1st screen and onto the 2nd screen.

Another enhancement I’m looking into is using Pygame instead of PD/GEM for visuals. PD/GEM wreaks havoc on any audio running in the same PD patch. I have Pygame installed on the zynthian, but when I try to run a pygame program from the terminal, it errors and xcb aborts. I’m searching for a solution and may have to post a detailed list of the error messages to see if anyone can help.

1 Like