New Staging (pre-stable) release: 2109

Hi @zynthianers!

We are close to a new stable release. There are some interesting changes in the workflow and many fixes and improvements. But not really big changes. We are trying to get a solid stable release before going deeper on a refactorization to improve the code architecture.

Here is the updated staging-2109 SD image:

Or you could try to update, specially if you already are in testing. If you have a stable that you use for music, consider burning a new sd-card.

For updating :

  • Access webconf => software => repositories
  • Check advanced
  • Select “staging-2109” on all repositories.
  • Save
  • Update Software
  • Reboot

Good luck … and good connection!!!

The changes:

  • New SFZ engine, sfizz. Is it a good replacement for inuxsampler? This is the question :wink:

  • Bye Bye internal FXs on fluidsynth. Welcome smoother fluidsynth! Specially when using many channels.

  • Controller groups. It allows having the engine’s controllers grouped in a meaning and useful way. No more navigate the controller screens looking for the parameter you want. Currently only a few engines have the grouping info, but we will be adding the rest in a few weeks or months.

  • BTW, we changed the instrument control screen workflow. Like that:

    • short-select => Enter controller screen selection mode
    • bold-select => Layer options
    • long-back => Sequencer
    • Long-learn => Audio Levels (ALSA mixer)
  • Virtual favorites bank. If you have favorites for an instrument, then you will see a favorites bank on first place. You still can use short-learn for favorites.

  • Snapshot options. When clicking a snapshot from the list, you will get am options menu with new interesting possibilities like:

    • load
    • load layers
    • load sequences
    • save
    • rename
    • set program
    • delete
  • Zynthian UI on VNC

  • When adding a FX to the chain, show FX presets if available.

  • Improve layer chain management. Now you can replace the synth engine or the first FX on a synthless layer.

  • Improve MIDI-learn touch action

  • New CUIAs:

    • NEXT
    • PREV
    • And more…
  • Customized controller maps for FluidSynth (SF2 soundfonts). Give a try to the new included soundfonts, specially this one:


  • The CV/Gate interface implementation is complete. 4 x CV-IN & 4 x CV-OUT, although not perfect yet, specially scaling and need lot of testing with different devices.

  • The select widget has been removed from a few menus.

  • You will see the intro screen until the UI is displayed.

  • And many many bug-fixes and little adjustments. And probably a bunch of new bugs, hopefully less and smaller.

And that’s all!

Please, report issues here or open a task on the issue tracker if you are sure you have a bug. And check if already reported, please.



I loaded the image and found …

  • With Fluidsynth, I expected the effects to not work for reverb/chorus, but they still do??
  • Adding the 3-band equaliser no-longer kills the FS reverb. Tick.
  • The “m” icon is not triggered by pitchbend
  • I like the “click select then move the selection” on the control screen. Tick.
  • I had programmed S1 to “modal load snapshot” , but it doesn’t work now. Something to do with the next item?
  • The “choices when loading a snapshot” is a good idea, but most of the time I just want to load one. It would be nice to have a fast way of doing that. I suppose it’s only one more click.
  • The snapshot choices remembers the last position you used, i.e. if you last saved, next time the default is to save not load. I think that’s confusing.

I’ll keep testing. Where’s the issue tracker?


Simply update. The last changes were not committed when building the image. I just updated the link with the latest updated image.

It’s an old “feature”. Please, open an issue on the tracking system :wink:

The “modal load snapshot” CUIA doesn’t exist any more. Now it’s “MODAL_SNAPSHOT”. Reconfigure your wiring layout.

We could use bold-select for direct loading. Open a task on the issue tracker system.

This is a feature, not a bug. If other people thinks it’s confusing, i would change it.


Selecting menu items on screen with a mouse is a bit counterintuitive. Previously, clicking on an item selected that item. Now, clicking anywhere will just select just the highlighted item. Not sure if that was intentional?

Touch input seems to work fine though.

Update, please

OK, so I needed to write the new image, then update - all done now.

I can’t get a MIDI map to work with FS now. As soon as I create the mapping (for whatever CCs) the sound stops. I can see M icon for the MIDI coming in (providing it’s not just a pitchbend, he he) but no sound comes out. When I remove the mapping the sound is back. Am I doing something wrong, or is this a bug?


After an update to staging-2109 branch the Zynthian does not restart and hence does not pick up the new behaviour. Upate was performed with webconf.

@jofemodo , thanks for the fixes on the M icon and the MIDI FX. Both work well.


I plan to release the stable-2109 by the end of this week. Please, keep testing!!
You can download the latest staging-2109 sd-image:



@jofemodo , did you see the issue tracker about the snapshots on the web interface?


HI All! My setup uses a Rpi4 and a Waveshare7 Touch Display. I am testing the headphones by itself and the Generic USB Audio using an Presonus Audiobox… I do not have an audio board. With release 2109 I get no audio from Sfizz and I get scrambled audio from the other synths. I tried 44.1k and 48k and I adjusted Alsamixer to no avail. Maybe I forgot to setup something. I will download the 0914 release and post my settings in the morning when I get to my office. Sam

Tried the 2109 staging branch again and still have an issue when using a mouse for input. Clicking on any menu item doesn’t select that item, but instead selects the currently highlighted item. To use a mouse you need to use the scroll wheel to move the highlight to the item you want, and the click anywhere on the screen to select.

I’m not up to speed at all with github, issue tracking and suchlike to flag it in that way :unamused: . Maybe I need a crash course in githubology?:sweat_smile:

i can confirming the same problem with mouse and Zynthian over VPN.

Hi ! I made a very quick test of the latest staging image (burnt with Etcher) with a Zynthian 4.4 official box not connected to the Internet. I’d get the splash (after maybe 20 seconds), then black screen, then nothing. (waited for several minutes). After a reboot : same thing.

I reverted to the stable image and it did work perfectly.

Could it be related to the fact there was no ethernet cable plugged ? (I can indeed see “error” displayed temporarily which is apparently due to this)

Looks like using the touch screen directly also has the same problem

I installed from then performed an update.

There is a problem with noVNC - the script is missing.

Sep 21 15:58:07 zynthian systemd[753]: novnc0.service: Failed to execute command: No such file or directory
Sep 21 15:58:07 zynthian systemd[753]: novnc0.service: Failed at step EXEC spawning /zynthian/zynthian-sw/noVNC/utils/ No such file or directory

Hi @jp8 !

I’m investigating your issue report.

Regarding the stable release, we are almost there. Yesterday i got my changes on sfizz merged on the main development version:

I was awaiting for this before releasing the stable-2109 because i want sfizz installed from deb package, so we can keep updated easily. I will test the next nightly deb-build from sfizz repo and if it works fine, i will release the stable-2109 tomorrow :wink:



The noVNC developpers has changed the script name from “” to “novnc_proxy”. I just fixed everything, so simply update and test.


One option is to have your install scripts checkout a specific commit from his repository