No highlight after REMOVE ALL

I noted after the MIXER update that when the REMOVE ALL option is used nothing is highlighted after the engines are cleared.

1 Like

Have you tried to update again?

Yeah. I updated just a couple hours ago. Same behavior. The current layers are deleted and the CPU icon displays a couple times briefly but nothing is highlighted after the REMOVE ALL. Turning the selection dial does return the highlight to the last item which is of course REMOVE ALL.

I saw his behaviour before MIXER was introduced as well.
When you move encoders, the selection is back

OK! It should be solved now. Update and test!


That seems to have fixed it, but I did see it happen once again. I will test more.

I have seen this a couple times including just now. Iā€™m guessing there is some remaining race condition that allows the UI to end up with no highlight on rare occasions.

Has anybody else seen this since it was fixed?

Is this after the Zynthian logo stops moving?

Yup, the CPU load indicator usually flashes right at the end of REMOVE ALL as well. It was just after that.

Are you moving the knob? I saw it once when I moved the knob while the remove was still going on.

Nope. Just click the encoder and wait. It is fairly rare making it one of those annoying problems to debug. :roll_eyes:

1 Like