No screens found


updating fine now but get these errors :

root@zynthian:~# systemctl stop zynthian
root@zynthian:~# /zynthian/zynthian-sys/sbin/
/zynthian/zynthian-sys/sbin/ 3: /zynthian/zynthian-sys/sbin/ source: not found

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.26-v7+ armv7l Raspbian
Current Operating System: Linux zynthian 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l
Kernel command line: bcm2708_fb.fbwidth=1824 bcm2708_fb.fbheight=984 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000 dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait
Build Date: 11 November 2016 11:59:59AM
xorg-server 2:1.18.4-2+rpi1 (
Current version of pixman: 0.33.3
Before reporting problems, check
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Wed Sep 6 15:05:20 2017
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
Fatal server error:
(EE) no screens found(EE)
Please consult the The X.Org Foundation support
for help.
(EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

again many thanks


Is the webconf working?

Are the configurations for the display, audio, wiring correct?

If you have a screen, that is not supported, you need to install it manually.


all was working before update hifiberry dac light waveshare 4" screen just white can still use webconf


and the waveshare4 overlay is copied by the update?


yes.its in there although its name is "waveshare35a-overlay"
with the extra "-overlay"
when i restart though webconf i get

open /dev/fb1 no such file or directory exists

and webconf has trouble reconnecting


i would try to get your display working with a non-zynthian image and compare the boot/overlay, when it’s working


i have just tried it with an adafruit 2.8 resistive tft and same results when reconfigured with webconf it hangs on restart with:
open /dev/fb1 no such file or directory exists
open /dev/fb1 no such file or directory exists
then blank screen on restart.


? You need exactly the files from the website of waveshare. I assume you copied some files the first time and forgot to apply it now after the clean install


I have the same issue with my waveshare32.

have you started from a fresh gordona lately?


yes i started with a fresh gorgonilla image and updated as usual it was all working prior to upgrade.


[ 44.278] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 44.279] (II) no primary bus or device found
[ 44.279] (II) LoadModule: “glx”
[ 44.280] (II) Loading /usr/lib/xorg/modules/extensions/
[ 44.286] (II) Module glx: vendor=“X.Org Foundation”
[ 44.286] compiled for 1.18.4, module version = 1.0.0
[ 44.287] ABI class: X.Org Server Extension, version 9.0
[ 44.287] (==) AIGLX enabled
[ 44.287] (II) LoadModule: “fbdev”
[ 44.287] (II) Loading /usr/lib/xorg/modules/drivers/
[ 44.288] (II) Module fbdev: vendor=“X.Org Foundation”
[ 44.288] compiled for 1.18.4, module version = 0.4.4
[ 44.288] Module class: X.Org Video Driver
[ 44.288] ABI class: X.Org Video Driver, version 20.0
[ 44.288] (II) FBDEV: driver for framebuffer: fbdev
[ 44.292] (WW) Falling back to old probe method for fbdev
[ 44.292] (II) Loading sub module “fbdevhw”
[ 44.292] (II) LoadModule: “fbdevhw”
[ 44.293] (II) Loading /usr/lib/xorg/modules/
[ 44.293] (II) Module fbdevhw: vendor=“X.Org Foundation”
[ 44.293] compiled for 1.18.4, module version = 0.0.2
[ 44.293] ABI class: X.Org Video Driver, version 20.0
[ 44.294] (EE) open /dev/fb1: No such file or directory
[ 44.294] (EE) No devices detected.
[ 44.294] (EE)
Fatal server error:
[ 44.294] (EE) no screens found(EE)
[ 44.294] (EE)
Please consult the The X.Org Foundation support
for help.
[ 44.294] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 44.294] (EE)
[ 44.303] (EE) Server terminated with error (1). Closing log file.


when I commented the second dtoverlay line in boot/config.txt, I get the screen back.
Not calibrated though.


in my case it was penirq=17,
without, it works again.


tried this not working for me though


Please go to webconf, choose Waveshare 4 GPIO only

and try to eliminate single values of this string:


I would start with removing penirq=17



How did you solve it?


new gorgonilla image to start with then apt get update && upgrade then the usual update method and i removed the penriq=17. which worked in the end. thank you very much for all the help. amazing synth


I removed the penirq in the webconf already and it should be in the master branch already