No sound from Pianoteq 8 Stage

,or pianoteq 7 stage, as an LV2 instrument.

Some background: I built a little test Zynthian on a Raspberry Pi 3 - which seemed lovely, but was clunky in my setup, and struggled with Pianoteq. This really is the Pianoteq box for me, so I was thrilled to be able to pick up somebody’s assembled kit, as they’re still sold out.

Shows up today. Everything works and produces sound except for the Pianoteq install. I run updates. I load up my copy of Pianoteq 8.0 STAGE.

Aaannnd… nothing.

Specifically, it gives me this error when I try to update the license to the machine:

Pianoteq Action Failed: Command '/zynthian/zynthian-sw/pianoteq6/pianoteq --activate xxxx-xxxx-xxxx-xxxx' returned non-zero exit status 2.

It also shows “not found” errors when I try to update from the unit itself.

Here’s my zynthian.local info.


The LV2 won’t even go past the midi channel select stage

…okay, nothing from the LV2’s makes sound. Other MIDI synths at the top (ZynAddSubFX, Set B Free, Fluidsynth, etc) seem to work fine.

I’mma reload the current Zynthios Stable and see if that helps.

Update: it did not.

Gonna grab a different SD card

Second Update: different card worked for the other issues, LV2 synths are playing. Pianotec demo played fine.

Just can’t get my paid copy to load.

Hi @Killstring! Welcome and good hunting.

I see you have fixed your issue. Sounds like a bad installation. I edited your post to remove your PT licence key that you won’t want the world to know. You can download the latest version of Pianoteq 8.0.5 from the user section of Modartt website. Remember that audio mutes after 20 minutest for demo instruments.

Ahh, I appreciate that. This was all going on at the end of a loooong night of work, so distraction and frustrations were multiplied.

The problem I am still having, is that I can’t get the Pianoteq authorization to go through. So I’m stuck with no Pianoteq, because I uploaded the latest version of Stage, but Zynthian isn’t letting me authorize my license.

Still getting

Pianoteq Action Failed: Command ‘/zynthian/zynthian-sw/pianoteq6/pianoteq --activate xxxx-xxxx-xxxx-xxxx’ returned non-zero exit status 2.

IIRC I entered the Pianoteq license though the VNC interface, for some reason the webconf didn’t work.

1 Like

@pau I’mma have to try that

Odd! It worked for me through webconf.

I’ll try it again when I reinstall one zynthian that is still running the 2109 version, but this will be next month. I’ll let you know.

1 Like

I appreciate it! I’m in the middle of tearing apart and rebuilding my home office, so free time is at a premium, lol.