Not able to push to github due to 403 error

I am not able to upload to my code to github due to the pain-in-the-ass error 403. Yes I use a token but git push results in an error. Really frustrating. I tried with Atom and with CLI (linux). Anybody had same experience and solved it?

Hi @Jan

403 error means you do not have permission to access the resource. If a user has been granted permission then this is often caused by incorrect authentication, e.g. wrong password / token value.

Which repository are you trying to push to? It would be rather unusual to grant a new user permission to write to a project repository so I would expect you would:

  • Fork the project
  • Push changes to your own forked repository
  • Submit pull requests against the upstream, core project

If you are trying to commit to the core repository ( then I would expect it to fail - unless @jofemodo has granted you write access - which would seem inappropriate / unorthodox / unusual practice.

Many thanks for answering. Problem solved by removing the fork and forking again. No errors anymore. Just did PR. Sorry for the garbage yesterday in the PR list.