Not able to read or load any GIG files with Zynthian LinuxSampler or Logic PRO

I’ve been exploring the synth engines in Zynthian (RPi 3B, latest stable + updates) and it’s been interesting discovering all the features. One reason I wanted to add this system to my small stable of software synthesizers is that it supports many different formats for samples and soundfonts as well as the other types of synthesis.

There’s a somewhat well known set of Mellotron samples available on the web in the .gig format - and many people praise the contents of the file. It’s known as “TaijiguyGigaTron” and it’s not too difficult to find. However, after downloading it (from two locations, just to be sure I wasn’t getting a corrupted copy) I can’t get it to open with either Logic Pro or Zynthian. LPX, despite claiming to support GIG files, crashes hard when trying to load the file, and Zynthian says “not a GIG file”. So I suppose the file is corrupt, but I have seen no one else report trying to load and use it with the known GIG file readers. Is anyone familiar with this file, or am I missing something? I do have plenty of other Mellotron sample sources, I was just hoping this one was usable because allegedly the curator spent a lot of time polishing it.

Since then, I downloaded a few other .gig files including the Conexant GM library, and none of them will load into Zynthian either. With any of the .gig files I’ve tried, I keep getting the error “Destiny is not a GIG file” no matter the name of the file. Clearly something is wrong, either with the files, Zynthian, or me! :grinning:

Did you see this previous, successful installation of this same GIG file?

Hi @GregDunn !

Current stable is not maintained anymore. You should verify that the issue is present in the latest Oram Bookworm SD image, but it’s not :wink: I just tested with latest Oram and it works flawlessly. Note that this soundfont is keyswitched, so you need to use low notes to change the “sound”. From the TaijiguyGigaTron documentation:

C0  M400 Violins
C#0 M400 Violins Yes EQ
D0  M400 Violins Smooth Ryder EQ
D#0 Cello
E0  String Section
F0  Mk II Violins
F#0 M300A (violins)
G0  M300B (solo violin)
G#0 Mk II Brass
A0  GC3 Brass
A#0 Mk II Flute
B0  Woodwind2
C1  Combined Choir


1 Like

I do have the issue with loading this GIG to my V5 via webconf. I get the same error message:

  • In webconf, create and select a bank in Linux Sampler
  • Enter “Mellotron” in the “Search Musical Artifacts” field an click the search icon
  • Click the “+” button
  • Error: “Can’t install URL: Destiny is not a GIG bank!”
1 Like

Then it’s the Musical Artifacts integration. I think this need some care …
I download and installed and it worked OK.


1 Like

I tried to manually install but it hasn’t worked. I see /zynthian/zynthian-my-data/soundfonts/sfz/Mellotron/TaijiguyGigaTron/ folder containing TaijiguyGigaTron_switched.gig and the folder appears in Linux Sampler but no instrument within the folder.

It looks like an upload issue putting it into the wrong location. Manually moving to /zynthian/zynthian-my-data/soundfonts/gig makes it available.

in my PC I have a folder MEL TaijiguyGigaTron
in the folder I have TaijiguyGigaTron_switched.gig

in ORAM May22
I copied with Filezilla the folder MEL TaijiguyGigaTron
in /zynthian/zynthian-my-data/soundfonts/gig
and I find the file after loading in a chain Linux Sampler

OK, first I’m going to try copying the file over to my Zynthian install, but I’m burning an Oram boot card now and will also try that. I hope to report back soon and let you all know what happened. Thanks for the info!

Sorry for the delay, and the longish upcoming post.

I tried several times to upload and install the Taijiguy GIG file to my Pi3 running latest-stable + updates. It either hangs uploading the file if I use webconf, or refuses to recognize it after uploading to the zynthian-my-data/soundfonts/gig via sftp and rebooting. The file remains in the directory, but Zynthian does not see it nor offer it as an instrument.

So I flashed my 32GB card with the 0524 version of ORAM and booted. It seems to run OK but does not recognize the LinuxSampler engine at all (the earlier release, 0324, did show LinuxSampler). I used webconf to initiate a sw update. it seems to complete normally (I have the log if needed) but LinuxSampler is still not available. It is checked in “Software/Engines” but fails to show up even after reboots.

I also have the issue where the VNC UI Menu is missing from the webconf (this was still visible in the March release), but connecting using VNC Viewer works just fine and I can access the main UI.

I am going to be fairly busy with other obligations for about a week, but hopefully will find time to check in if there are any new updates or suggestions. Thanks to all for the helpful guidance so far.

Synth engines and effects plugins are divided into groups in Oram. You need to use the left/right arrows or “learn/shot” encoder to change group. LinuxSampler is in the “Sampler” group.

1 Like

Wow. OK, not being familiar with the hardware Zynthian, I didn’t get the significance of the “category” value. Indeed, left/right arrows allow me to choose the category and LinuxSampler is of course available - along with the B3 emulator and some other stuff I hadn’t got around to using yet.

The GigaTron situation took a bit longer to sort out. As @piattica hints, uploading the GigaTron directory/folder, not just the .gig file, to the zynthian/zynthian-my-data/soundfonts/gig folder via sftp was necessary. After doing that, it shows up as a LinuxSampler instrument and the keyswitched individual samples are accessible. Apparently the software uses the directory name to categorize the sample set in the UI and doesn’t assign a slot if it’s not in a folder?

Still learning all the intricacies of Zynthian, but at this point everything except the native VNC UI is working - and as mentioned, I can get to that via VNC viewer, so it’s not a problem really.

I do want to note than on my pi3, the 64-bit Zynthian is noticeably faster and smoother than the 32-bit version. Can’t wait for my Pi4 to arrive this week so I can start to assemble a proper Zynthian.

1 Like

Also, while I’m thinking about it - am I taxing the 1GB memory of my Pi in using instruments with huge samples like some of the grand pianos? I’ve tried to load the Salamander piano instrument but it freezes before completing the load. All the other sampled instruments seem to work just fine but I know this thing has a massive amount of sample data…

Yes! If you load data that is larger than the available RAM the machine will either crash or start using swap. I don’t think Zynthian is configured to use swap. If it were, the machine would slow to a crawl.

I thought this might be a problem. I’ll just work with the smaller sample sets and synth engines till my Pi4 arrives.

Linux sampler and sfizz implement dynamic loading of samples and don’t load all samples in memory. Just what it needs. It loads the first fragment of each sample and the rest when the note starts. When needed, it also unload samples not used frequently, etc

You should be able to use salamander with Linuxsampler or sfizz. Try both, please, and send report


At first, the LinuxSampler Salamander piano V3 and V3 retuned crashed the synth every time I loaded them, requiring a reboot. The V2 worked just fine. After I got V2 to load, now V3 (both versions) seem to be loading OK. I was able to switch presets without a problem. It does seem to take a moment to fully load, after the “wave” indicator stops moving.

I was careful to remove all chains before trying to load the Salamander instrument but that seems to have made no difference as now that it is loading correctly I don’t need to do that to change piano versions (which is good). It’s very odd, because I would expect similar behavior when repeating the same steps but it has been a little inconsistent at first. Perhaps my Pi (which I bought used) has something flaky in the hardware. Another good reason to get the Pi4 in place asap.

I was reluctant to use both sfizz and linuxsampler but I have somecases that require one or another.

I.e. SCC Expressive Strings makes linuxsampler use 100% of CPU and it gets stuck.

And If I use some Accordion instruments in sfizz I getxruns all the time but run fine with linuxsampler.

Si I’ve decided to try both every time :slight_smile:

1 Like

It would be nice to flag each soundfont so it get open with the “best choice”. Somebody should open a ticket for this :wink: