OBXd crashes on startup

Hey everyone,

Today I built my Zythian kit and it’s been working really well, except that I ran into an issue trying to load the obxd plugin. When I try to load obxd in a new layer, even when all other layers are empty, I get a red error screen with no other information on it. The system then has to be rebooted to recover.

This is on a fresh install of the latest stable zynthian OS. Sorry, since I’m kind of new to this, I’m not sure how I can provide more debug information. Has anyone else run into this issue?

Hi @jacquiepi,

Welcome to our community. I hope you will enjoy your adventures in Zynthianland.

I am not seeing the issue you describe. Will you please paste a screenshot or the content from your webconf homepage which will show us things like the versions of core modules in use?

Do you have any other engines loaded? Which MIDI channel, preset do you attempt to select in Obxd or at what point does the error occur? What does the error show? What version of the kit did you build or when & where did you obtain it?

Sorry - lots of questions but this will all help to hone in on the issue.

1 Like

So here is a screenshot from the webconf homepage. It’s essentially stock, except that I changed the Kit to “Custom” and the soundcard to RBPi onboard audio so that I could test the audio with my headphones. I did that because I saw another user on the forums said to do that to get sound from the 3.5mm RBPi jack.

The crash occurs whether or not I have another synth engine loaded. Also, today I tried it with the default soundcard and 1/4" stereo out, and had the same issue with that plugin. Here’s a picture of the error screen, sorry if it’s bad quality:

As for the version of the OS, I installed it from the here, selecting the “last stable” version: https://os.zynthian.org/
Not sure what version that is exactly.

I also had this problem with the latest build. I switched to the “testing” branch, and after updating and rebooting a couple of times it went away.

Unfortunately I no longer have a debug log. I believe the problem is not in OBXd itself, but is in the process that rebuilds presets, which does a lot of processing in the background and then segfaults. You can get the log by restarting the UI in debug mode, and then loading OBXd, which will eventually cause the UI to crash.

Okay, so I’ve been very busy at work lately and haven’t been able to look into this until now…

When I try to load the plugin while viewing the debug log in the webconf dashboard, here’s what I get:
May 27 08:54:54 zynthian startx[507]: WARNING:zynthian_autoconnect.cb_jack_xrun: Jack Audio XRUN!
May 27 08:57:21 zynthian startx[507]: ERROR:zynthian_lv2.get_plugin_presets: Can’t load presets cache file ‘/zynthian/config/jalv/presets_Obxd.json’: [Errno 2] No such file or directory: ‘/zynthian/config/jalv/presets_Obxd.json’
May 27 08:57:21 zynthian startx[507]: lilv_world_add_plugin(): warning: Reloading plugin http://moddevices.com/plugins/mod-devel/mod-cv-switch1
May 27 08:57:21 zynthian startx[507]: lilv_world_add_plugin(): warning: Reloading plugin http://moddevices.com/plugins/caps/CEO
…and so on for hundreds of lines of plugins until:
May 27 08:57:21 zynthian startx[507]: lilv_world_add_plugin(): warning: Reloading plugin http://plugin.org.uk/swh-plugins/modDelay
May 27 08:57:39 zynthian startx[507]: ./zynthian.sh: line 144: 578 Segmentation fault ./zynthian_gui.py

So the xrun appears to be incidental given the time difference. All the plugins reload, and then there is 18 seconds or so of silence in the log and a mysterious segfault. It seems like I am missing the file ‘/zynthian/config/jalv/presets_Obxd.json’. Unfortunately, I couldn’t find that file in my Windows install of Obxd on my PC, either (I was hoping I could copy it over that way).

Does anyone know if there is a way to re-compile just Obxd without having to re-format a new image of the OS?

Try the attached presets file, from /zynthian/config/jalv/presets_Obxd.json.

I think the “.json” file is basically just an index of the distributed LV2 “.ttl” preset files. Something is obviously a bit wrong with the process that builds this index. Have you done a software update on your system? Perhaps the problem is already fixed. It certainly works properly in the “testing” branch.

presets_Obxd.json (257.9 KB)

Thank you, that fixed it. Still not sure why that file was missing, but everything is working now and I was able to load a patch on Obxd!

1 Like

Did you try to regenerate the presets cache by clicking the “search for new plugins & presets” button, on the webconf LV2 tab?


That must be worth :face_with_monocle:

If this makes no sense press on the frwoning icon…