Older Eleduino screen, works [in Zynthian] (Solved, it was gremlins or something...)

***Update: For future searchers, I bounced around with the screen working and not (and also interpreting an unrelated problem as a screen problem), but eventually I settled on “Generic HDMI Display” with the following in the webconf’s Config field, and it seems to working fine after multiple reboots and such:

hdmi_cvt 1024 600 60 3 0 0 0

Hey yall, so I’ve been experimenting with Zynthian boxes with the stuff I’ve got at hand cause I’m broke, and one pretty decent bit of my gear at hand is this touchscreen that I’ve had for quite a while - Product page is here:

Anyways, the screen works beautifully on Zynthian with my Pi3 - I add the lines at the bottom of the above link to /boot/config.txt and it works a charm.

On my Pi4, it boots up a vanilla RaspiOS image without even changing the config.txt, but I get a blank screen in Zynthian.

Anyone got any clues as to what’s happening with the RPi4 and this screen vis-a-vis Zynthian? It should work as a standard HDMI screen, or so the propaganda claims.

One thing I noticed that might be significant: I was following breadcrumbs from other forum posts relating to other issues, and I noticed that although the official product page seems to specify a 60Hz refresh in the hdmi_cvt line, I installed and ran edid-decode in RaspiOS, and according to it, the screen was running at 43ish Hz. 43.x, can’t remember exactly.

I would obviously very much prefer to run Zynthian on my 4 than my 3, but ignorance torments me. I’ve been running the staging image but I’m currently imaging the stable onto another SD card, on the possibility that it’s a bug in the RC. Also going to experiment with that hdmi_cvt as soon as the imaging is done.

But, any ideas from the more experienced among us is greatly appreciated - I took the Pi3 Zynth to practice with my new band yesterday and there many oos and ahs when I showed them just how much stuff was packed in there, even if I can only have a couple of engines running on that mobo.

1 Like

Are you editing using the webconf? Changes will get blatted otherwise.

Yes, I meant to say that I added it to the hardware page, sorry.

I initially got it going by editing config.txt directly and that was my “victory moment” which was stolen from me later that day when I updated the software. :>

But yes, I did learn shortly after that to modify the webconf rather than the system files lol

***I actually tried installing and running the same edid-decode command on my Pi3 Zynth’s terminal, but the /sys/class/drm path doesn’t exist, which is probably a clue also.

1 Like

Well, it seems to have sorted itself out. I was certain that I had attempted setting the Display to “Generic HDMI Device” and had it not work, but for whatever reason that worked today.

I strongly suspect now, that I have gremlins, and they enjoy making things not work just long enough for me to post about it in a forum.

Must have been a solar flare…

1 Like

If you are using the new staging image then we fixed an issue with this last week. I have a similar screen that was not being detected properly and the gods sprinkled fairy dust until it shone. Do remember that Zynthian currently only sends video to one of the RPi4 HDMI outputs.

Do I need to manually download the latest image, or can I run update in the webconf? It’s giving me a No Smoking symbol when I go to click update in the Update page. Definitely want to be using the latest build. :>

The purist would download the latest test build…

And then updates from there.This is probably the cleanest route and means you work from a common starting point.

If you are using update it is frequently a good idea to do it twice.