One encoder sounds very different than the rest, and doesn't work

I’m going through the test steps of my new build, and one encoder (used for Layer) has a much sharper “click” sound (which I noticed while assembling), than the quiet, soft click of the others as they rotate. I’m getting no response on either rotation direction from it when in a synth layer, though clicking works. I’ve checked the connections, and the harness seems good, and both ends are well-seated.

Is there anything else I can do to test if the encoder is bad?

Have you tried to connect an encoder that is working on another port? Just to make sure it’s not the cable or port.
I also have an encoder that does sound a little bit different than the others, but it’s working.

1 Like

Looks like a bent pin inside the connector on the board. Trying to delicately align it with a dental pick now…

Edit: Hallefuckinglujah. It was just coincidence that the loud encoder also was on the bad jack. I saw there was also a tiny fleabite on the channel in the plug that mated with the board connector, so I imagine there was a bit of flash or something that misdirected the pin on insertion. My own fault for not checking the connectors before plugging them in. Works now!


Happy that it’s working now :+1:

1 Like

Aaah Excellent !! encoder probably consume about 25% of all my zynthian attention, and it can be really distracting ( lacking the back switch is one of the worst to fight) keep a mouse handy and turn on the cursor :smiley: )

So glad you tracked it down, which, of course, brings us to the inevitable… :face_with_monocle:


“lacking the back switch” meaning power? Why would a synth have a power switch? I think the only synth I own with a power switch is my Eurorack case…

My Mininova has one :stuck_out_tongue:

I mean, I know there are a few, but . . . it’s definitely not normal. I think people complaining about that can’t have been in either the arduino/rpi world or the studio/electronic music world for long.

All my synths have power buttons but that wasn’t what @wyleu was talking about. He was referring to the BACK button within the bottom left encoder which navigates back through the menu system.