Pi zero w 2

They have released a quad core pi zero! Got my order in already… Anyone else?

Zynth Zero perhaps?

Control panels…

I already wanted to order one, because… PI!
But supply is limited and I don’t really need one so I hope someone will put ‘my’ zero 2 to good use.

5GHz WLAN would have been nice, but well…
I understand that the connectors haven’t been updated to micro HDMI and USB-C to stay compatible with the zero 1… But wireless stuff?
Maybe would have been to costly or there is no space for an 5GHz pcb antenna

It is only going to give Pi3 performance and has micro USB so I don’t have a particular use for it, yet. I still haven’t used the zero I bought for a fluidsynth player because that project went away. It is good to see a more powerful, small form factor device but the price hike is another blocker for me. We do now have a wider range of devices available. I guess the very low end is covered by the pico (a rather different device) so it makes sense to spread the market.

Good luck to RPF and those who play with the new device. I too will be donating my allocation back into the pool for the general good of humanity :slight_smile:.

From the Eben Upton interview:
“Real time performance is around three times the speed. A Raspberry Pi Zero takes around 90 seconds to boot into the GUI, whereas Raspberry Pi Zero 2 W takes around 30 seconds.”

Tom’s Hardware has been testing one for a while.

Raspberry Pi Zero 2 W Review: The Long Awaited Sequel


Presumably the top entry is for No Heatsink.

The top two results have the same legend!

Legendary fail :wink:
Let’s assume that the lower numbers are with heatsink.

My conclusion: a fan does make a difference, but a passive heatsink is probably not worth it.

Well - I just got a Pi Zero 2W a couple of days ago. I added a 5" HDMI resistive touchscreen (a Waveshare clone). The combo runs standard Raspbian OS just fine, once I added a wpa-supplicant.conf for my wifi and the display driver from the manufacturer.

Then I tried the latest Zynthian distro. Wifi has been an issue from the beginning. Editing zythianos-wpa-supplicant.txt seems to have no effect getting wifi to start. What did work temporarily, is to add an empty ssh file and a new wpa-supplicant.conf in the boot partition. I was then able to get into the web config and quickly added my Wifi network. I also managed to set the sound card to dummy, since Zynthian seems to assume a HiFi Berry default. After a brief interval, usually a minute or less, Wifi drops and the Pi is no longer reachable. I have no clue why (I have noted that others have struggled to get headless Pis without ethernet to behave).

Curiously the Zynthain interface on the HDMI display comes up with no error warnings. Slight overscan at the bottom. Unfortunately, the touchscreen calibration is wonky (like 180 degrees upside-down), so not great.

IMG_1344

So it is basically functional, which is encouraging, but unless I can keep the wifi working, I can’t do much with the config. My next step will probably be to try adding an ethernet/USB hub hat to the Pi to see if Ethernet will get me further along. Of course, this essentially yields me a Pi 3B so is kind of silly, but maybe if I can figure out the Wifi stuff it can be removed.

We’ll see…

I found that setting the screen resolution in webconf helped with over-scanning display.

Have you tried touchscreen calibration in the admin menu?

The problem is that I only get a few seconds of time with the interface before wifi quits and disconnects me. One thing I have not tried yet is the hotspot mode - which might help. I saw a post by someone who could not get wifi to work but hotspot did.

Here is an update: I was able to get hotspot mode enabled, reduce the vertical size of the display slightly, and re-enabled wifi. At that point, wifi started to work and continues to work. This makes no sense except that entering and exiting hotspot mode seems to have cleared it up!

I was then able to do a software update. I also enabled VNC. I could not scroll down on the touch screen to get to the calibration tool, but I could scroll down to it from VNC. However, the calibration tool did not clear up the upside-down touch response, so I need to find which configuration file controls that.

Good progress, but I’ll need to keep experimenting!

EDIT Trying the calibration tool a couple of times and a few reboots solved the touch problem. Not sure why it did not “take” initially. Anyway, my headless Zero2 is now pretty functional. Next step will be to add my Audio Injector card and try some MIDI in. Also, have a GPIO expander handy so will try adding encoders.

If the Zero2 proves to be at all useful for running Zynthian, at some point, I might try to start over from scratch and see if I can document a more sensible approach to getting this working. If so, I will pass on what I have discovered to the author of the wiki page which describes headless installation (but not using ethernet as he documented).

Cheers!

You say it makes no sense, but it kinda does. There hasn’t been a zynthian os update since the new zero dropped, and zynthian was never designed for a zero. Realistically, if we set our expectations right, we definitely should be able to get it going, but it’s up to us, if we want zynthian on a zero. Going forward though, there should be no reason that we can’t get it working for a future release, if we work at it.

So. Let’s think about and set the expectations correctly. Personally, I always thought the pi 3 was missing that final bit of grunt to make it a good platform for zynthian. The pi 4 really unlocked the box of tricks I now use.

That’s why mentioned the idea of “zynthian lite”. I think it could work as a single instrument solution, but not the whole zynth as we know it.

What do you think the end game should be?

I don’t know if there is an endgame with Raspberry Pis - the foundation will continue to make new and more capable computers, so it is a moving target.

One could argue that the Pi 4 has become too pricey right now. I paid $15 for my Zero 2W, so I think that it opens up new opportunities for DIYers on a budget. The 4 is great, but so are the new compute modules.

Keeping up with and supporting evolving hardware, newer kernels, etc. is a real challenge, of course.