Pi4 and Hifiberry pro

No, that was important.
Are you using the latest image from os.zynthian.org?
I see a broken fluidsynth from a couple of months ago

Yes, the screenshot of the dashboard doesn’t fit to the log…

Its from 06.04.2020 i think …

I will try [ ] 2020-04-14-zynthianos-buster-lite-1.0.0.zip

But i thought the DAC runs well … hhhmmmm why not mine :rofl: :rofl: :rofl: :rofl: :rofl:

Ok i download and let you know …

Now i got the new image and i got sound but really noisy cracky … And i can adjust the volume via the ALSA mixer … But the sound is really poor :frowning:

if i record with the audio recorder everything is clear and good (but no wonder its before the DAC :-))

Has someone suggested psu yet?

Its an original PI4 PSU …

Now I unmounted the hifiberry.

Only pi4 zynaptik display and usb midi keyboard and usb soundcard and it works …
When I switch to generic usb soundcard in the webconfic…

Strange strange …

Hopefully I didn’t kill the hifiberry …

It sounds from the clip like the input is looped directly to the output, the white noise stops if you play a sound. There’s some sort of gate effect happening.

I think it’s time to burn a raspbian and see if the card is ok. I’m not saying there’s a zynth problem but you need to make sure all your components actually do what they are meant to. A lot of the signs seem to indicate everything is working, but that will at least indicate the overall health of the card.

Have you run alsamixer and turned some switches?

Yes I did and the volume control work but with this crazy sounds if I play a synth.

I will try raspian and see if it works there and let you know …

But thanks all so far for your help :+1:

Oh,don’t worry, we will get our reward!!

OK under raspian it works well…

Now I tried it without the Zynscreen and it worked also.
And finally I found a little smash in my display :frowning: And every time I connect the display the hifiberry won’t work.

Also my touch functionality won’t work … I think my zynscreen is broken … but crazy display work without touch and also the encoders … but it seems to conflict with the hifiberry …

I dont need the touch functionality is it possible to turn off in the webconfig ? Could this be a solution ?

Dr Snuggles would say it only can be the bus cable or the zynscreen :frowning:

no,there’s no option for this: https://github.com/raspberrypi/firmware/blob/master/boot/overlays/README#L1803

you will have to disable it in the overlay (https://github.com/raspberrypi/linux/blob/d2b14d32d3e417e5ef9434bb8ec9f1229035ee2e/arch/arm/boot/dts/overlays/piscreen-overlay.dts) and compile the modified version

I’d argue it’s probably not working because of a short or damage, I doubt disabling software would make much of a difference.

1 Like

I would tend to agree with @Baggypants a display with issues has enough connections to things to do all kinds of complicated disruption . . . :pensive: (but prove us wrong, if you can :smiley: )

You could disconnect the display, and plug an external HDMI monitor in and fire the zynth up on that by setting display in webconf.

Ok hopefully I get a chance :slight_smile: all that strange things come up if I only plugin the buscable :slight_smile: but where to get any of these cables on Sunday :smiley:

1 Like

Hi together,

Here my next try with the Zynthian and the Electribe :blush:

stay safe and healthy and again

Thanks Zynthianers for make this thing work ! I love my Zynthian so far :blush:

3 Likes

Nice try, @Bavaria-Rene !! :wink:
I just added to the video demos on the wiki.

Please, could you share the snapshot or tell something about the engines and presets you used?

Thanks a lot for sharing!!

Hi, @jofemodo

here the Snapshot :slight_smile:

005.zss (30.4 KB)

And again thanks for your work !!!

Rene

1 Like