Pi5 & Oram, strange thing happened

I thought yesterday that I had somehow killed my Pi5, but it seems that the EEPROM is getting scrambled by booting with the 5-22 image of Oram on SD, BUT I have not tested extensively with a bog standard Raspbian image for very long, so not assuming yet that it’s Oram.

The sequence of events to now, as I have tentatively reconstructed it:

-attempted to get a frankenzynth setup with my Boss GP-10 and my Pi5
-Pi5 bricks itself, I do not connect it to an event, but LED error codes say EEPROM
-reflash with “Boot from SD” utility image
-attempt to boot Oram again, dies
-at some point yesterday I realize that one of my last two not-in-use SD cards is dead also
-give up and go cook a ton of indian food, my current other obsession is watching videos of Indian women and cooking dishes I have been unable to cook my whole life, it’s amazing

This morning so far:
-reflash with Utility image again
-Boot with Raspbian, works. Did not leave it running long, just verified that Pi is not murdered (yay!)
-write Oram to SD card (working with a single card, but it’s only a couple months old and not heavily used)
-Starts booting, I have a generic HDMI plugged in from doing the bootloader
-after about 30 seconds of what looks like boot activity on the LEDs it locks up, Red light goes on, bricked.
-Reflashed bootloader with utility again
-just booted it with Rasbian again

Other things I can think of, I used raspberry Pi Imager software to write the SD on my Windoze laptop, selecting the Oram image in the custom OS option. Not sure if it checks the write under those conditions, or just for OSes that it has explicitly added. I did, however, check the checksum on the downloaded zip file and it matched.

Might be worth investigating what is entailed in getting Zynthian into that app, by the way? I realize it would just be stable but still, you seen some of the two-bit apps they got in there? We need to gentrify that shit.

I’m gonna run some stress on it under raspbian (I do have active cooling) before I try booting Oram again, but interested in any thoughts. Also gonna pick up some brand new SDs asap just to be sure it’s not that.

1 Like

ORAM May22: RPI5 does not boot

Could it be traceable to what happened to me?

Seems to be the same behavior. Did you ever sort it out?

Edit: since I booted with raspbian it’s been sitting there happily, I’ve run a few things. Definitely something on the Oram image, you ask me.

Maybe the autodetect routines that determine your kit and such, poking somewhere it doesn’t want to be poked?

My HW is not an official kit.

Neither is mine - I’m fairly certain if I stuck it in my official kit (with pi4) it would be fine, though I should try that actually…

edit: meant to say though, on first boot the OS examines your hardware and attempts to ascertain whether you are a kit or not - it’s possible that this hardware poking is what makes the Pi angry, is my thinking.

1 Like

Something similar is happening to me with my Raspberry Pi 5. I have flashed the SD card with the latest version (2024-05-22) without any peripherals (screen, sound card, etc.), and when booting, the green light starts normally, even begins to blink indicating that it is loading the system, but after 2-3 seconds, the red light stays on. I can’t connect it to the network to check anything, nor does it load anything on the screen.

Following the same steps with the previous version (2024-05-04), the boot worked correctly, and I could even connect to zynthian.local via RJ45 to start configuring the setup.

I think there is something wrong with last week’s version and the Raspberry Pi 5. I have tried looking for log files on the SD card using Linux Reader, but I haven’t found anything relevant.

I realize this might be a big ask and too much effort for this specific problem, but there is a serial console port on the Pi which puts out messages related to the boot process and might tell us what is going on here.

On the Pi5 it is a " Qwiic" connector between the mini HDMI ports. The function is available on earlier Pi’s via GPIO pins.

1 Like

I have the adapter I do believe - will have a go in the morning. Was thinking that myself.

1 Like

Can I still do it via GPIO? These are the two devices I have for serial interfacing…

I believe that the GPIO pins would still work, although I don’t know for sure.

I also noticed that they will show up on an HDMI monitor:
Not sure if that also applies to Pi5.

more useful links:

Boot diagnostics

If an error occurs during boot, then an error code will be displayed via the green LED. Newer versions of the bootloader will display a diagnostic message which will be shown on both HDMI displays.


I am going on a trip, but will check in daily if possible,

The same thing happens for me every time. It is very easy to recover the eeprom, but again…

The LED error code is not useful, “spi eeprom error” which, duh.

That being said, it seems that enabling pins 14&15 is a configurable option in the bootloader, default off, so I might have to wrangle with that a bit first…


1 Like

I’ve been noodling with config.txt and raspi-config all morning but I cannot get any sign that those GPIO pins are talking to the world. Documentation is terrible, everything assume Rpi4. Very “ez” thanks RPiFoundation.

yeah, they do some kind of “obfuscations” around many parts of their ecosystem (like RBPi5 schematic or RP1 southbridge full documentation, test points location for example).

Wait and see, I believe things should go better.

These few days I’m testing Oram and have done a couple of fresh install / update on a RBPi3 or RBPi4. When installing headless, I’ve got exactly the same behaviour with some kind of “frozen system” or so. I always had to hard reboot 2 or 3 times before it goes up (network, webconf and so on).

Once everything is up, my RBPi4 won’t do a clean reboot while it’s just ok with my RBPi3 (and with same setup <=> SD Card) …

Being as I have a V5 kit, I was considering launching the fresh image in the kit, and then changing the setup in the webconf and dropping it into the 5. Might give that a go, but I’m kinda angrily trying to make the Pi talk to the UART pins.

If it doesn’t smarten up I’m taking its heatsink away. To punish it.