Pianoteq 8: Classical Guitar

Zynthian does not list the newer Classical Guitar instrument pack for Pianoteq 8.

from Pianoteq81.prefs

VALUE name=“subl” val=“Harp:A;D4:A;Guitar:A;Celeste:A;Steelpans:A;Vibes:A;Xylo:A”

Hey… I’m a smart guy… maybe I’ll PR this myself…

presets_cache.json needs…

"Classical Guitar": [["Classical Guitar Warm", null, "Warm", null], ["Classical Guitar Arpeggio", null, "Arpeggio", null], ["Classical Guitar a la piano", null, "a la piano", null], ["Classical Guitar Prelude", null, "Prelude", null], ["Classical Guitar", null, "<default>", null], ["Classical Guitar Gentle", null, "Gentle", null], ["Classical Guitar Triple", null, "Triple", null], ["Classical Guitar 12 Strings", null, "12 Strings", null], ["Classical Guitar Bouzoukish Dream", null, "Bouzoukish Dream", null], ["Classical Guitar Electrified", null, "Electrified", null], ["Classical Guitar Electric Jazz", null, "Electric Jazz", null], ["Classical Guitar Purists", null, "Purists", null], ["Classical Guitar Dirty", null, "Dirty", null], ["Classical Guitar Cosmic Bow", null, "Cosmic Bow", null], ["Classical Guitar Stacatissimo", null, "Stacatissimo", null], ["Classical Guitar Melodic Vibrato", null, "Melodic Vibrato", null], ["Classical Guitar Tapping", null, "Tapping", null], ["Classical Guitar Microtuned", null, "Microtuned", null]],

zynthian_engine_pianoteq.py needs…

	bank_list_v8_0 = [
		('Classical Guitar', 0, 'Classical Guitar', 'Guitar:A')
                        self.bank_list = self.bank_list_v8_0 + self.bank_list

Well… the branches on your git really confuse me… your testing branch put these lines in zynthian_engine_pianoteq6.py… my pi doesn’t even have that file, as these lines go in zynthian_engine_pianoteq.py… So I’ll just leave this here i guess.

My Zynthian seems to be stuck on stable 2109, so maybe this is already fixed. Even though I keep changing it in Software > Repositories, it keeps reverting back.

The current version of Zynthian has improved Pianoteq interface for V7.5 and above. It no longer used the static list of instruments but instead gets the list from Pianoteq via it’s new API. Please read the release notifications about how to upgrade.

1 Like

The web ui’s Repositories page doesn’t seem to work… I’m trying to update using command line. Otherwise, I guess I’ll just reimage the thing…
Thanks for your help.

Hi @bigmalletman !

Could you explain the steps you followed and the issues you found?
AFAIK, the webconf repositories & update page works quite well, so we would need more details to reproduce and fix the issues you have.

Also, could you tell something about your zynthian setup? Having some context normally helps to understand and fix issues. For instance, a screenshot from your webconf’s dashboard would be a good starting point.

Thanks a lot!

1 Like

I wasn’t really familiar with the Repositories/Update area. I hadn’t used my Zynthian in a while, because in my last show, I needed to use Mainstage. In truth, I had not re-imaged my SD card since I got my Zynthian V4 back in 2020, so it was long overdue anyway.
Anyway, I tried to upgrade through the web, but it said I was already up to date. That’s when came where and also I added lines to make Guitar work.
I noticed things weren’t correct when I looked at github, so I clicked on Repositories and tried to change all my “stable 2109” to “stable”… but each time I tried to update, it seemed to revert back to “stable 2109”.
Since I just finished my gig and don’t have another for a bit, I decided it was time to just reimage… Plus this is the preferred method to upgrade based on the blog post.

We strongly recommend you to download and burn the new SD image. Trying to upgrade from previous stable versions is a long and error prone process so we have decided to block it to avoid people’s complains. Old stable versions can’t be upgraded!

And that was good enough for me.

I’m not having any issues on the latest build. After I re-imaged, I also updated. I uploaded Pianoteq 8.1 Pro, and it works. The menus are calling it “Standard” again, so I guess that isn’t right. The UI looks quite different, so I’ll need to learn it.

Sorry to bother.